summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-02 21:44:12 -0800
committerMatt Turner <mattst88@gentoo.org>2019-03-02 21:45:23 -0800
commit78925d7a2cdac37e74219558419b862d81e6a9c5 (patch)
tree675ac71b24e44f580f39b47025e12e4a24831442
parentnet-mail/courier-imap: amd64 stable wrt bug #676732 (diff)
downloadgentoo-78925d7a.tar.gz
gentoo-78925d7a.tar.bz2
gentoo-78925d7a.zip
x11-apps/xinit: Only print postinst messages first time
Closes: https://bugs.gentoo.org/440454 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-apps/xinit/xinit-1.4.0-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/x11-apps/xinit/xinit-1.4.0-r1.ebuild b/x11-apps/xinit/xinit-1.4.0-r1.ebuild
index a8b0150bc16d..f8dedbb1ce77 100644
--- a/x11-apps/xinit/xinit-1.4.0-r1.ebuild
+++ b/x11-apps/xinit/xinit-1.4.0-r1.ebuild
@@ -56,12 +56,15 @@ src_install() {
pkg_postinst() {
xorg-2_pkg_postinst
- ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
- ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
- ewarn "any executable. When you run startx, it will run this as the login session."
- ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
- ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
- ewarn "Here's an example of setting it for the whole system:"
- ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
- ewarn " env-update && source /etc/profile"
+
+ if ! has_version 'x11-apps/xinit'; then
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+ fi
}