summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-20 06:21:38 +0000
committerSam James <sam@gentoo.org>2021-03-20 06:21:38 +0000
commit7894b5c71eef0a171809ab4e8ea197397734a4c3 (patch)
treee1464c9a8b021626079c07dd560278408a0df31e
parentapp-crypt/tpm2-totp: minor style changes, add bug ref to patch (diff)
downloadgentoo-7894b5c71eef0a171809ab4e8ea197397734a4c3.tar.gz
gentoo-7894b5c71eef0a171809ab4e8ea197397734a4c3.tar.bz2
gentoo-7894b5c71eef0a171809ab4e8ea197397734a4c3.zip
app-arch/atool: fix bashism in configure script
Closes: https://bugs.gentoo.org/775158 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/atool/atool-0.39.0-r1.ebuild15
-rw-r--r--app-arch/atool/files/atool-0.39.0-configure-bashism.patch12
2 files changed, 26 insertions, 1 deletions
diff --git a/app-arch/atool/atool-0.39.0-r1.ebuild b/app-arch/atool/atool-0.39.0-r1.ebuild
index 4ab3fb6b4aec..b5a2d655b278 100644
--- a/app-arch/atool/atool-0.39.0-r1.ebuild
+++ b/app-arch/atool/atool-0.39.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Script for managing file archives of various types"
HOMEPAGE="https://www.nongnu.org/atool/"
SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
@@ -14,3 +16,14 @@ KEYWORDS="amd64 ppc x86"
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}
!app-text/adiff"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.39.0-configure-bashism.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for the bashism patch
+ eautoreconf
+}
diff --git a/app-arch/atool/files/atool-0.39.0-configure-bashism.patch b/app-arch/atool/files/atool-0.39.0-configure-bashism.patch
new file mode 100644
index 000000000000..512bdc02ee9f
--- /dev/null
+++ b/app-arch/atool/files/atool-0.39.0-configure-bashism.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/775158
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,7 +11,7 @@ AC_DEFINE_DIR(LOCALSTATEDIR, localstatedir)
+ dnl Perl stuff
+ AC_PATH_PROG([PERL], [perl])
+ eval `$PERL -V:startperl`
+-if test "${startperl:0:1}" = "#" ; then
++if test "$(printf %.1s "$startperl")" = "#" ; then
+ startperl="\\$startperl"
+ fi
+ AC_SUBST(PERL_SHEBANG, $startperl)