summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-05 15:16:46 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-05 15:25:28 +0200
commit78989e922a74a7a1f7f3dc05a2053562a0e0979b (patch)
tree93ae52df9c03e2d351827ce0243df6288c20f011
parentdev-libs/libfastjson: take up maintainership; update metadata (diff)
downloadgentoo-78989e92.tar.gz
gentoo-78989e92.tar.bz2
gentoo-78989e92.zip
dev-libs/libfastjson: bump to EAPI 8; minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.8-r1.ebuild (renamed from dev-libs/libfastjson/libfastjson-0.99.8.ebuild)16
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.9-r1.ebuild (renamed from dev-libs/libfastjson/libfastjson-0.99.9.ebuild)16
2 files changed, 14 insertions, 18 deletions
diff --git a/dev-libs/libfastjson/libfastjson-0.99.8.ebuild b/dev-libs/libfastjson/libfastjson-0.99.8-r1.ebuild
index d708a382d6a2..8d9063c9799e 100644
--- a/dev-libs/libfastjson/libfastjson-0.99.8.ebuild
+++ b/dev-libs/libfastjson/libfastjson-0.99.8-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
@@ -13,28 +13,26 @@ SLOT="0/4.2.0"
KEYWORDS="amd64 arm arm64 ~hppa sparc x86"
IUSE="static-libs"
-DEPEND=">=sys-devel/autoconf-archive-2015.02.04"
-RDEPEND=""
+BEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+
+DOCS=( AUTHORS ChangeLog )
src_prepare() {
default
-
eautoreconf
}
src_configure() {
local myeconfargs=(
- --enable-compile-warnings=yes
$(use_enable static-libs static)
--disable-rdrand
+ --enable-compile-warnings=yes
)
-
econf "${myeconfargs[@]}"
}
src_install() {
- local DOCS=( AUTHORS ChangeLog )
default
- find "${ED}"usr/lib* -name '*.la' -delete || die
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
}
diff --git a/dev-libs/libfastjson/libfastjson-0.99.9.ebuild b/dev-libs/libfastjson/libfastjson-0.99.9-r1.ebuild
index e398fef4b3d2..56d3287ed32a 100644
--- a/dev-libs/libfastjson/libfastjson-0.99.9.ebuild
+++ b/dev-libs/libfastjson/libfastjson-0.99.9-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
@@ -13,28 +13,26 @@ SLOT="0/4.3.0"
KEYWORDS="amd64 arm arm64 ~hppa sparc x86"
IUSE="static-libs"
-DEPEND=">=sys-devel/autoconf-archive-2015.02.04"
-RDEPEND=""
+BEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+
+DOCS=( AUTHORS ChangeLog )
src_prepare() {
default
-
eautoreconf
}
src_configure() {
local myeconfargs=(
- --enable-compile-warnings=yes
$(use_enable static-libs static)
--disable-rdrand
+ --enable-compile-warnings=yes
)
-
econf "${myeconfargs[@]}"
}
src_install() {
- local DOCS=( AUTHORS ChangeLog )
default
- find "${ED}"usr/lib* -name '*.la' -delete || die
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
}