summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-27 06:01:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-27 06:01:27 +0200
commit78d3aa92915a5a4d8a13480f60aa3fd1e3b7ba86 (patch)
tree318492411d28eae6e7c33d9c02b4a7866105dbfc
parentdev-python/botocore: Bump to 1.29.142 (diff)
downloadgentoo-78d3aa92915a5a4d8a13480f60aa3fd1e3b7ba86.tar.gz
gentoo-78d3aa92915a5a4d8a13480f60aa3fd1e3b7ba86.tar.bz2
gentoo-78d3aa92915a5a4d8a13480f60aa3fd1e3b7ba86.zip
dev-python/boto3: Bump to 1.26.142
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.142.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d667a16706e9..238272830303 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.26.138.gh.tar.gz 651104 BLAKE2B 58c7c71c97567b167d9c0afc376161b6015
DIST boto3-1.26.139.gh.tar.gz 651459 BLAKE2B ba1c0c45c0cd78622ca34bcbfb3c8961c0555ed9fa16d8cb89363880d8cf6911183758ed7e4f44a098413b47d2d6b3c1ee4e57f05561947d7660a969e4e7be2d SHA512 971ce067318642e2f4a13cb77b29410d97b5c8e7cff28e76d7983f95bb5f593697bebc6d744517b5c7e760b5b30980370befe86a97d1162882a13428833b0a5b
DIST boto3-1.26.140.gh.tar.gz 651805 BLAKE2B 2b58cee4e5c199af29e359790abfbb6eb536be3ded95aead640fdf179a0150875753cc9d066b70b08b0f9db6ef12d9fd3e5dbc4d9c481872f894c24a5f279f5f SHA512 f73fddf2674ee0bdbca37b6231d9b512286c73f5e815573eadb1f8ae855749a58492eed20fd03a2494392b7f146c86ba355ed2381aefbc5251fcae366749c277
DIST boto3-1.26.141.gh.tar.gz 652608 BLAKE2B 8e11b0cdc694f751dfa99391a2364b3c809c8f5f9bbcd37341fb44f14d49a9c702f812cb76ea7ec1473f7ce32ffef62bc86d28664ce7f88bf44f23ea86516b1d SHA512 441b8e76fd658fc1146b0df0734e3ad8c0ffb4afa284387615dcd6706f3d4efb6af8e61f1a62b4e0b9aa6a516aa9c63d7b627c6c0f37b24375fa5091d1672181
+DIST boto3-1.26.142.gh.tar.gz 655602 BLAKE2B e9d5671308e71bb43a97953407f4aba5b78594ed39b26c3c992af9db8864e3c363ab874a66b5b015083c4a18fe7415bb1761137367783a70ff22564ada8a8842 SHA512 c2eabdb47898aa26fc8ba8a8ebfa43a86153188af1f1600bfa741bd3af1ce68a8692e461aecb5a29df94885e1c977b06c3cd009f1cec52a2e7a9dc853a2c3942
diff --git a/dev-python/boto3/boto3-1.26.142.ebuild b/dev-python/boto3/boto3-1.26.142.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.142.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}