summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 15:58:25 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:26:41 +0100
commit78d46b5ed652734487e07c9ffd7e697d4cc5f947 (patch)
tree46c56ff0041f311607b96c8637fe34a98a46e429
parentmate-extra/caja-dropbox: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-78d46b5e.tar.gz
gentoo-78d46b5e.tar.bz2
gentoo-78d46b5e.zip
media-gfx/alembic: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-gfx/alembic/alembic-1.7.11-r1.ebuild (renamed from media-gfx/alembic/alembic-1.7.11.ebuild)6
-rw-r--r--media-gfx/alembic/alembic-1.7.9.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/media-gfx/alembic/alembic-1.7.11.ebuild b/media-gfx/alembic/alembic-1.7.11-r1.ebuild
index eaf86523653f..8f112f0a4fd3 100644
--- a/media-gfx/alembic/alembic-1.7.11.ebuild
+++ b/media-gfx/alembic/alembic-1.7.11-r1.ebuild
@@ -28,10 +28,12 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
>=media-libs/openexr-2.3.0:=
- boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_USEDEP}] )
hdf5? ( >=sci-libs/hdf5-1.10.2:=[zlib(+)] )
- python? ( >=dev-python/pyilmbase-2.3.0[${PYTHON_USEDEP}] )
+ python? ( >=dev-python/pyilmbase-2.3.0[${PYTHON_SINGLE_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.11-r1 )
+ $(python_gen_cond_dep '
+ boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_MULTI_USEDEP}] )
+ ')
"
DEPEND="
${RDEPEND}
diff --git a/media-gfx/alembic/alembic-1.7.9.ebuild b/media-gfx/alembic/alembic-1.7.9.ebuild
index 7acd86b893c6..c04e8c9b6f6b 100644
--- a/media-gfx/alembic/alembic-1.7.9.ebuild
+++ b/media-gfx/alembic/alembic-1.7.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,10 +28,12 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
>=media-libs/openexr-2.2.0-r2:=
- boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_USEDEP}] )
hdf5? ( >=sci-libs/hdf5-1.8.18[zlib(+)] )
- python? ( >=dev-python/pyilmbase-2.2.0[${PYTHON_USEDEP}] )
+ python? ( >=dev-python/pyilmbase-2.2.0[${PYTHON_SINGLE_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.11-r1 )
+ $(python_gen_cond_dep '
+ boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_MULTI_USEDEP}] )
+ ')
"
DEPEND="
${RDEPEND}