summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-20 18:17:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-20 18:33:38 +0200
commit78e2d9bc5892cb41df78ba897e809e31db4cfc03 (patch)
tree891769b2eaca36fa43be23483c520814ccb17f83
parentgui-apps/liquidshell: new package, add 1.9.0 (diff)
downloadgentoo-78e2d9bc5892cb41df78ba897e809e31db4cfc03.tar.gz
gentoo-78e2d9bc5892cb41df78ba897e809e31db4cfc03.tar.bz2
gentoo-78e2d9bc5892cb41df78ba897e809e31db4cfc03.zip
gui-apps/xwaylandvideobridge: new package, add 0_pre20230819
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--gui-apps/xwaylandvideobridge/Manifest1
-rw-r--r--gui-apps/xwaylandvideobridge/metadata.xml11
-rw-r--r--gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/gui-apps/xwaylandvideobridge/Manifest b/gui-apps/xwaylandvideobridge/Manifest
new file mode 100644
index 000000000000..2e3f771adec2
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/Manifest
@@ -0,0 +1 @@
+DIST xwaylandvideobridge-0_pre20230819-8842032f.tar.gz 34466 BLAKE2B 7407638cab2476f56c6e0b402e8683af7145e9acc47240635161bc780467eafa91cc11d720916ac3ce36e401bda65b8d9a244de994cd72193c58ca385f0b1f2a SHA512 8ea099fa2719b715d35eadc5224477470a6ca226bb388098b4c1423a62f23c1e7c52222093cb126e2af7f898be5a04f63294d350d4907aaf35e2e726940477d4
diff --git a/gui-apps/xwaylandvideobridge/metadata.xml b/gui-apps/xwaylandvideobridge/metadata.xml
new file mode 100644
index 000000000000..170f61584cfe
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="kde-invent">system/xwaylandvideobridge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild
new file mode 100644
index 000000000000..97ce7e415fc4
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+KDE_ORG_CATEGORY="system"
+KDE_ORG_COMMIT="8842032fe672575a9dfe44adc7ef84b468d931fe"
+inherit ecm kde.org
+
+DESCRIPTION="Screenshare Wayland windows to XWayland apps"
+HOMEPAGE="https://planet.kde.org/david-edmundson-2023-03-22-fixing-wayland-xwayland-screen-casting/
+https://invent.kde.org/system/xwaylandvideobridge"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-plasma/kpipewire-5.27.4:5
+ media-libs/freetype
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ ecm_src_prepare
+ # https://invent.kde.org/system/xwaylandvideobridge/-/merge_requests/14
+ ecm_punt_kf_module WidgetsAddons
+}