summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-26 16:53:23 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-07 18:19:05 +0100
commit78e46af2b6049bac487e46341294e75ba01db59b (patch)
tree24e7b78d0899a217318fb072c820f7bf43b99d2d
parentapp-portage/iwdevtools: drop 0.12.8 (diff)
downloadgentoo-78e46af2b6049bac487e46341294e75ba01db59b.tar.gz
gentoo-78e46af2b6049bac487e46341294e75ba01db59b.tar.bz2
gentoo-78e46af2b6049bac487e46341294e75ba01db59b.zip
app-emulation/xen: rename USE=efi to USE=uefi
Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--app-emulation/xen/metadata.xml2
-rw-r--r--app-emulation/xen/xen-4.16.6_pre1.ebuild14
-rw-r--r--app-emulation/xen/xen-4.17.3_pre1.ebuild17
3 files changed, 16 insertions, 17 deletions
diff --git a/app-emulation/xen/metadata.xml b/app-emulation/xen/metadata.xml
index 68e9c297bc42..bad2422fe3f9 100644
--- a/app-emulation/xen/metadata.xml
+++ b/app-emulation/xen/metadata.xml
@@ -16,6 +16,6 @@
<use>
<flag name="boot-symlinks">Symlink xen.gz variants in /boot, disable on fat filesystems</flag>
<flag name="flask">Enable the Flask XSM module from NSA</flag>
- <flag name="efi">Adds efi boot support, requires LDFLAG -melf_x86_64 for amd64</flag>
+ <flag name="uefi">Adds UEFI boot support, requires LDFLAG -melf_x86_64 for amd64</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/xen/xen-4.16.6_pre1.ebuild b/app-emulation/xen/xen-4.16.6_pre1.ebuild
index cde7b44a75ed..c16c9bcc93b3 100644
--- a/app-emulation/xen/xen-4.16.6_pre1.ebuild
+++ b/app-emulation/xen/xen-4.16.6_pre1.ebuild
@@ -47,12 +47,12 @@ S="${WORKDIR}/xen-$(ver_cut 1-3 ${XEN_BASE_PV})"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+boot-symlinks debug efi flask"
+IUSE="+boot-symlinks debug uefi flask"
REQUIRED_USE="arm? ( debug )"
DEPEND="${PYTHON_DEPS}
- efi? ( >=sys-devel/binutils-2.22[multitarget] )
- !efi? ( >=sys-devel/binutils-2.22 )
+ uefi? ( >=sys-devel/binutils-2.22[multitarget] )
+ !uefi? ( >=sys-devel/binutils-2.22 )
flask? ( sys-apps/checkpolicy )"
RDEPEND=""
PDEPEND="~app-emulation/xen-tools-${PV}"
@@ -90,7 +90,7 @@ src_prepare() {
fi
# Symlinks do not work on fat32 volumes # 829765
- if ! use boot-symlinks || use efi; then
+ if ! use boot-symlinks || use uefi; then
eapply "${XEN_GENTOO_PATCHES_DIR}"/no-boot-symlinks/${PN}-4.16-no-symlinks.patch
fi
@@ -100,7 +100,7 @@ src_prepare() {
# Drop .config
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
- if use efi; then
+ if use uefi; then
export EFI_VENDOR="gentoo"
export EFI_MOUNTPOINT="/boot"
fi
@@ -163,12 +163,12 @@ src_compile() {
src_install() {
# The 'make install' doesn't 'mkdir -p' the subdirs
- if use efi; then
+ if use uefi; then
mkdir -p "${D}"${EFI_MOUNTPOINT}/efi/${EFI_VENDOR} || die
fi
xen_make DESTDIR="${D}" -C xen install
# make install likes to throw in some extra EFI bits if it built
- use efi || rm -rf "${D}/usr/$(get_libdir)/efi"
+ use uefi || rm -rf "${D}/usr/$(get_libdir)/efi"
}
diff --git a/app-emulation/xen/xen-4.17.3_pre1.ebuild b/app-emulation/xen/xen-4.17.3_pre1.ebuild
index 9d75fa2cbfe3..2d80429a137e 100644
--- a/app-emulation/xen/xen-4.17.3_pre1.ebuild
+++ b/app-emulation/xen/xen-4.17.3_pre1.ebuild
@@ -47,12 +47,12 @@ S="${WORKDIR}/xen-$(ver_cut 1-3 ${XEN_BASE_PV})"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+boot-symlinks debug efi flask"
+IUSE="+boot-symlinks debug uefi flask"
REQUIRED_USE="arm? ( debug )"
DEPEND="${PYTHON_DEPS}
- efi? ( >=sys-devel/binutils-2.22[multitarget] )
- !efi? ( >=sys-devel/binutils-2.22 )
+ uefi? ( >=sys-devel/binutils-2.22[multitarget] )
+ !uefi? ( >=sys-devel/binutils-2.22 )
flask? ( sys-apps/checkpolicy )"
RDEPEND=""
PDEPEND="~app-emulation/xen-tools-${PV}"
@@ -78,7 +78,7 @@ pkg_setup() {
die "Unsupported architecture!"
fi
fi
- use efi && secureboot_pkg_setup
+ use uefi && secureboot_pkg_setup
}
src_prepare() {
@@ -91,7 +91,7 @@ src_prepare() {
fi
# Symlinks do not work on fat32 volumes # 829765
- if ! use boot-symlinks || use efi; then
+ if ! use boot-symlinks || use uefi; then
eapply "${XEN_GENTOO_PATCHES_DIR}"/no-boot-symlinks/${PN}-4.16-no-symlinks.patch
fi
@@ -101,7 +101,7 @@ src_prepare() {
# Drop .config
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
- if use efi; then
+ if use uefi; then
export EFI_VENDOR="gentoo"
export EFI_MOUNTPOINT="/boot"
fi
@@ -164,17 +164,16 @@ src_compile() {
src_install() {
# The 'make install' doesn't 'mkdir -p' the subdirs
- if use efi; then
+ if use uefi; then
mkdir -p "${D}"${EFI_MOUNTPOINT}/efi/${EFI_VENDOR} || die
fi
xen_make DESTDIR="${D}" -C xen install
- if use efi; then
+ if use uefi; then
secureboot_auto_sign --in-place
else
# make install likes to throw in some extra EFI bits if it built
rm -rf "${D}/usr/$(get_libdir)/efi"
fi
-
}