summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 14:52:49 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-09 14:52:49 +0200
commit78ea560bf340ddf1b98f9752f9d0b55141ceaf9c (patch)
treeeda79278f1faa32b0bb5a325fc5987cb9596233d
parentsys-apps/mawk: add changelog (diff)
downloadgentoo-78ea560b.tar.gz
gentoo-78ea560b.tar.bz2
gentoo-78ea560b.zip
sys-apps/cracklib-words: add 2.9.7
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-apps/cracklib-words/Manifest1
-rw-r--r--sys-apps/cracklib-words/cracklib-words-2.9.7.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/cracklib-words/Manifest b/sys-apps/cracklib-words/Manifest
index e76b8720e503..f5579fec8223 100644
--- a/sys-apps/cracklib-words/Manifest
+++ b/sys-apps/cracklib-words/Manifest
@@ -1 +1,2 @@
DIST cracklib-words-2.9.6.gz 5536645 BLAKE2B b0ac23e8777cb094cec565e9728ca8dd37359cd19c2e2d4cd215635f462e464fb27fc5a9e560895804df4e519c465845b381a8cd47fb4d6f9b9c62109ff661e6 SHA512 fc5bbe7699c9c9e3f39f5c82f53ec8a4ea85e08d5513188a2f6423f92779008b87d85cfcf87a9a5d13a49b04c30f73890cd4d3fa7cd4a6bdac5c1ebc18e18bc3
+DIST cracklib-words-2.9.7.gz 5537586 BLAKE2B 242afa5e3615b159c59d27c99b87f008f245351cc7e4bd8dc975e66b4ef98456841c6a213282744d39c221c8646dc8e0c5ad99f277f37ae3e64bc949f6b57187 SHA512 1fa34b0a2e16d6906982b248f1757bf5bf8154d8d7e8bab94a4ac25080c41434d3828a2c8dd5065e9be586f36480ab70375f09e0bb64eb495d96a460619e2bae
diff --git a/sys-apps/cracklib-words/cracklib-words-2.9.7.ebuild b/sys-apps/cracklib-words/cracklib-words-2.9.7.ebuild
new file mode 100644
index 000000000000..a0f525cb573b
--- /dev/null
+++ b/sys-apps/cracklib-words/cracklib-words-2.9.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Note: ideally bump with sys-libs/cracklib
+DESCRIPTION="Large set of crack/cracklib dictionaries"
+HOMEPAGE="https://github.com/cracklib/cracklib/"
+SRC_URI="https://github.com/cracklib/cracklib/releases/download/v${PV}/${P}.gz"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ insinto /usr/share/dict
+ newins ${P} ${PN}
+}
+
+pkg_postinst() {
+ if [[ -n "${ROOT}" ]] && create-cracklib-dict -h >&/dev/null ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict /usr/share/dict/* >/dev/null
+ eend $?
+ fi
+}