summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:46 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:14 +0000
commit78f04f9fdc55670d2a2d5263a92f7a19dfe99bfc (patch)
tree670b2959b0604b3dc8c8b2fe40874a9b67e7b3f8
parentgnustep-base/gnustep-base: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-78f04f9fdc55670d2a2d5263a92f7a19dfe99bfc.tar.gz
gentoo-78f04f9fdc55670d2a2d5263a92f7a19dfe99bfc.tar.bz2
gentoo-78f04f9fdc55670d2a2d5263a92f7a19dfe99bfc.zip
mate-extra/caja-dropbox: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mate-extra/caja-dropbox/caja-dropbox-1.24.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/mate-extra/caja-dropbox/caja-dropbox-1.24.0.ebuild b/mate-extra/caja-dropbox/caja-dropbox-1.24.0.ebuild
index d1965d7f5745..13c899c9f5c5 100644
--- a/mate-extra/caja-dropbox/caja-dropbox-1.24.0.ebuild
+++ b/mate-extra/caja-dropbox/caja-dropbox-1.24.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python3_7 )
MATE_LA_PUNT="yes"
-inherit mate python-single-r1 linux-info user
+inherit mate python-single-r1 linux-info toolchain-funcs user
if [[ ${PV} != 9999 ]]; then
KEYWORDS="amd64 x86"
@@ -77,7 +77,7 @@ src_install() {
mate_src_install
- local extensiondir="$(pkg-config --variable=extensiondir libcaja-extension)"
+ local extensiondir="$($(tc-getPKG_CONFIG) --variable=extensiondir libcaja-extension)"
[ -z ${extensiondir} ] && die "pkg-config unable to get caja extensions dir"
# Strip $EPREFIX from $extensiondir as fowners/fperms act on $ED not $D.