summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-11 19:15:40 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-11 20:16:02 +0200
commit78f9480382911aee179e459d26c6e8dd3cc47683 (patch)
tree3d6cdcd10dd8a5323e2ae2e2dfa60d1740434a6d
parentgnome-base/gvfs: bump to 1.38.2 (diff)
downloadgentoo-78f94803.tar.gz
gentoo-78f94803.tar.bz2
gentoo-78f94803.zip
gnome-base/gnome-session: bump to 3.30.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-base/gnome-session/Manifest1
-rw-r--r--gnome-base/gnome-session/gnome-session-3.30.1.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/gnome-base/gnome-session/Manifest b/gnome-base/gnome-session/Manifest
index 6d0cda94e65d..1fce49bb03b0 100644
--- a/gnome-base/gnome-session/Manifest
+++ b/gnome-base/gnome-session/Manifest
@@ -2,3 +2,4 @@ DIST gnome-session-3.24.2-xorg-default-translations.patch.xz 3392 BLAKE2B afe0e0
DIST gnome-session-3.24.2.tar.xz 783288 BLAKE2B 24b06404b9206a53f394db86a90f9c22c2774432bcb33f136eedd333e813139ded8b9445b4e597f3270ec0b2ef167ce3c2dca2c5b75d5fba977ebcfc4c1bb8ea SHA512 52a609d60303e7d733567cc81698fe4a4042ac17d0260aadb334ab8ad2c355086f8f87c2bcac05f659c28f8f3290128f9ca8875806d199ee27ff84d972333e27
DIST gnome-session-3.26.1.tar.xz 782676 BLAKE2B 68ffae002910f827dca372402b8e014298b12fc892d6e6c477ff8ba0f793c98cd28f4a974c5665ac8bf7d61f485e4c662ba2f96cb3fd9bdec4a6218e86a797db SHA512 a4c2e82306ae044c56b857c8f7347dc5d5235231e702d2ac38c8c433e21efc75ca3911ee029af01754685f64000a0e6f5d17408192208b19d7dc367079ee7b0a
DIST gnome-session-3.28.1.tar.xz 480196 BLAKE2B 37bd2138c0610f5cbaa77d558a02f025e2df3105d1b07a3e41f06078215c06c01d47fd6803cb72ee05ccc98765b46221fc618e2b7c3e091398c4420d5be8a015 SHA512 ceeacb3cb4729d4b0a646220097a49359d1eb85ec20cd5d5a44c273b661d41ee83caaf6598def06c4e89b5f785f9317b1171b5550bf8f5634bc882a21e5e685b
+DIST gnome-session-3.30.1.tar.xz 485996 BLAKE2B 6882aa9f6004dc6da5070a484d92450bd1e8f61885492edf11260d9834fcae700f113a8ddeb1d905171432400ad9e94fba99ed6eaa49f08efd2d0ec2dffd9c5a SHA512 b6bc98da0245cdefa7e462b1f4e2c9198ee0da1f15a426d377331f79aec2f637bef27b093780c77f7ffbe7eb62c6829acdbd9f9e25cac5a4f6ed0da6ab96359a
diff --git a/gnome-base/gnome-session/gnome-session-3.30.1.ebuild b/gnome-base/gnome-session/gnome-session-3.30.1.ebuild
new file mode 100644
index 000000000000..8674fec66da3
--- /dev/null
+++ b/gnome-base/gnome-session/gnome-session-3.30.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Gnome session manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-session"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="consolekit doc systemd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.46.0:2
+ >=x11-libs/gtk+-3.18.0:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=gnome-base/gnome-desktop-3.18:3=
+ >=dev-libs/json-glib-0.10
+ media-libs/mesa[egl,gles2]
+ media-libs/libepoxy
+ x11-libs/libXcomposite
+
+ systemd? ( >=sys-apps/systemd-183:0= )
+ consolekit? ( >=dev-libs/dbus-glib-0.76 )
+"
+
+# Pure-runtime deps from the session files should *NOT* be added here
+# Otherwise, things like gdm pull in gnome-shell.
+# gnome-settings-daemon is assumed to be >=3.27.90, but this is about
+# removed components, so no need to strictly require it (older just
+# won't have those daemons loaded by gnome-session).
+# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
+# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
+# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
+# sys-apps/dbus[X] is needed for session management.
+# Our 90-xcursor-theme-gnome reads a setting from gsettings-desktop-schemas.
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-settings-daemon-3.23.2
+ >=gnome-base/gsettings-desktop-schemas-0.1.7
+ sys-apps/dbus[X]
+ consolekit? ( sys-auth/consolekit )
+
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-user-dirs-gtk
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ x11-libs/xtrans
+ virtual/pkgconfig
+ doc? ( app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2 )
+"
+
+src_prepare() {
+ xdg_src_prepare
+ # Install USE=doc in $PF if enabled
+ sed -i -e "s:meson\.project_name(), 'dbus':'${PF}', 'dbus':" doc/dbus/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeprecation_flags=false
+ -Dsession_selector=true # gnome-custom-session
+ $(meson_use systemd)
+ $(meson_use systemd systemd_journal)
+ $(meson_use consolekit)
+ $(meson_use doc docbook)
+ -Dman=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ dodir /etc/X11/Sessions
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/Gnome"
+
+ insinto /usr/share/applications
+ newins "${FILESDIR}/defaults.list-r4" gnome-mimeapps.list
+
+ dodir /etc/X11/xinit/xinitrc.d/
+ exeinto /etc/X11/xinit/xinitrc.d/
+ newexe "${FILESDIR}/15-xdg-data-gnome-r1" 15-xdg-data-gnome
+
+ # This should be done here as discussed in bug #270852
+ newexe "${FILESDIR}/10-user-dirs-update-gnome-r1" 10-user-dirs-update-gnome
+
+ # Set XCURSOR_THEME from current dconf setting instead of installing
+ # default cursor symlink globally and affecting other DEs (bug #543488)
+ # https://bugzilla.gnome.org/show_bug.cgi?id=711703
+ newexe "${FILESDIR}/90-xcursor-theme-gnome" 90-xcursor-theme-gnome
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version gnome-base/gdm && ! has_version x11-misc/sddm; then
+ ewarn "If you use a custom .xinitrc for your X session,"
+ ewarn "make sure that the commands in the xinitrc.d scripts are run."
+ fi
+
+ if ! use systemd && ! use consolekit; then
+ ewarn "You are building without systemd and/or consolekit support."
+ ewarn "gnome-session won't be able to correctly track and manage your session."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}