summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-27 23:33:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-28 00:16:05 +0200
commit7908c238efcf3824f1d3c899ff8c00da2a12aade (patch)
tree061e57f829de4842809eb33efcb40ed9062bab1a
parentdev-python/django-mptt: Bump to 0.13.4 (diff)
downloadgentoo-7908c238efcf3824f1d3c899ff8c00da2a12aade.tar.gz
gentoo-7908c238efcf3824f1d3c899ff8c00da2a12aade.tar.bz2
gentoo-7908c238efcf3824f1d3c899ff8c00da2a12aade.zip
dev-python/doc8: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/doc8/Manifest1
-rw-r--r--dev-python/doc8/doc8-0.9.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/doc8/Manifest b/dev-python/doc8/Manifest
index 02a4c2b515fb..e5144e18d0bb 100644
--- a/dev-python/doc8/Manifest
+++ b/dev-python/doc8/Manifest
@@ -1,2 +1,3 @@
DIST doc8-0.6.0.tar.gz 21547 BLAKE2B 84908a28e46fa970db7510d5fec7815028b9e65bec3cb5c0352f4ed88560765bde4c76aea3ba803ce737dff1856b702b21cebcf151587f6ae2870d4d1126d0a5 SHA512 1858334d3a0247d4d30c311bd7f13be66a6cdb6131f9d24dc10e38efaed6e08c8c7d11b776ff5dac7d6ae5eeb1cb7ef03523bc3e244794625a8ac1346cc05d75
DIST doc8-0.9.0.tar.gz 30995 BLAKE2B 9960e223e9ada9646a0e302230714dbeef1525bf9a912ec1b7a8a0c5e4bf2d2307c2303524668d770ddb38d0b30e4a868e5a2280b7c6ffc1b4b80854f2576e75 SHA512 ebff512dfffb7d21d9173f0ff6ca282810334abfbd9c95570dba4e27796e79bc8d14fd2914c029a3cbf235766305dfa37ca565e2e20d32c63ea741f8ce4d1ae2
+DIST doc8-0.9.1.tar.gz 31122 BLAKE2B 84708d05414fe1545558910d0d74ae9612091500efb1880062910b395f1244c6edb1fe1c95ff97a177fcbb4127fcbc4b819a749f90c8384c0c23e9041af12b25 SHA512 058403a808ec2d55cf732c8eb0e28f6902c935a6fe0fd4e3ce1a11088888f32875a416adf478b81192948ebd581548b2d1591581222f1e841e97777980a80d69
diff --git a/dev-python/doc8/doc8-0.9.1.ebuild b/dev-python/doc8/doc8-0.9.1.ebuild
new file mode 100644
index 000000000000..e7f37e7f4c45
--- /dev/null
+++ b/dev-python/doc8/doc8-0.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="http://git.openstack.org/cgit/stackforge/doc8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/restructuredtext-lint[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "checking pyproject.toml projects" dev-python/toml
+}