summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-25 17:31:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-25 18:05:35 +0200
commit790bb170cc4b04eaae1bb8d3f26b33a59ea16232 (patch)
treec362aa9c369a7ed61850dfdd7cc04c2f0b65b5b5
parentx11-drivers/nvidia-drivers: add 525.116.03 (diff)
downloadgentoo-790bb170cc4b04eaae1bb8d3f26b33a59ea16232.tar.gz
gentoo-790bb170cc4b04eaae1bb8d3f26b33a59ea16232.tar.bz2
gentoo-790bb170cc4b04eaae1bb8d3f26b33a59ea16232.zip
dev-python/scipy: Fix ignoring tests with !pooch
Closes: https://bugs.gentoo.org/904975 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/scipy/scipy-1.10.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/scipy/scipy-1.10.1.ebuild b/dev-python/scipy/scipy-1.10.1.ebuild
index f4f38cab6482..c04548669025 100644
--- a/dev-python/scipy/scipy-1.10.1.ebuild
+++ b/dev-python/scipy/scipy-1.10.1.ebuild
@@ -94,24 +94,24 @@ python_configure_all() {
}
python_test() {
- cd "${T}" || die
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
local EPYTEST_DESELECT=(
# Network
- datasets/tests/test_data.py::TestDatasets::test_existence_all
- datasets/tests/test_data.py::TestDatasets::test_ascent
- datasets/tests/test_data.py::TestDatasets::test_face
- datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
+ scipy/datasets/tests/test_data.py::TestDatasets::test_existence_all
+ scipy/datasets/tests/test_data.py::TestDatasets::test_ascent
+ scipy/datasets/tests/test_data.py::TestDatasets::test_face
+ scipy/datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
)
local EPYTEST_IGNORE=()
if ! has_version -b "dev-python/pooch[${PYTHON_USEDEP}]" ; then
EPYTEST_IGNORE+=(
- datasets/tests/test_data.py
+ scipy/datasets/tests/test_data.py
)
fi
- epytest -n "$(makeopts_jobs)" --pyargs scipy
+ epytest -n "$(makeopts_jobs)" scipy
}
python_install_all() {