summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-24 10:45:36 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-30 10:40:33 +0200
commit79208fe716eddf58b20f4f37695a44f2ba746f7b (patch)
tree20aa72ffb4e108975ef242985eb67a692b643f32
parentdev-java/jopt-simple: update upstream metadata (diff)
downloadgentoo-79208fe716eddf58b20f4f37695a44f2ba746f7b.tar.gz
gentoo-79208fe716eddf58b20f4f37695a44f2ba746f7b.tar.bz2
gentoo-79208fe716eddf58b20f4f37695a44f2ba746f7b.zip
dev-java/commons-daemon: add 1.3.1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25617 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/commons-daemon/Manifest1
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.3.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/commons-daemon/Manifest b/dev-java/commons-daemon/Manifest
index 49470d61307c..b9b13542b265 100644
--- a/dev-java/commons-daemon/Manifest
+++ b/dev-java/commons-daemon/Manifest
@@ -1 +1,2 @@
DIST commons-daemon-1.2.4-src.tar.gz 281929 BLAKE2B 877f1c31024a2f3e4796abdd11059bd636444f5c856b998a39761fb0b221467e986586fef43463a4d01b4d4f7a562f9f8c658b94a124cd356b0a70cc185c0030 SHA512 36e9cb3153ca763bfaaa71575a1584610254f1ce4c0f666ff7bbc628311405430536413525c9c777e4364eea62a247fb084750d837e84a62d9fce92a61909d56
+DIST commons-daemon-1.3.1-src.tar.gz 287642 BLAKE2B 02e85a5534af7f804a0374789506ee25ee8313987c68153974aa938b983745ae44d579f17deb362764d1a03b04bc552115bd69ef28b4f7d3bbb06f3bb4199814 SHA512 b810ac152f8296d980a4fb3786eff9d147b234dc2377df5fe1bded0824c694c9e82a7ef50b0a63c3e6432dfc4684a3aa2ce8d583aacb740bd4664c3dfb8b8f16
diff --git a/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild b/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild
new file mode 100644
index 000000000000..7822d682f36a
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/daemon/source/commons-daemon-1.2.4-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-daemon-1.2.4.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="commons-daemon:commons-daemon:1.3.1"
+# JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple toolchain-funcs
+
+DESCRIPTION="Tools to allow Java programs to run as UNIX daemons"
+HOMEPAGE="https://commons.apache.org/proper/commons-daemon/"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+DOCS=( {CONTRIBUTING,README}.md {HOWTO-RELEASE,NOTICE,RELEASE-NOTES}.txt )
+HTML_DOCS=( PROPOSAL.html )
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+
+# There is only org/apache/commons/daemon/SimpleDaemon.java
+# which is not even run upstream ( mvn test ).
+# JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+# JAVA_TEST_SRC_DIR="src/test/java"
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ pushd src/native/unix || die
+ ./configure
+ emake AR="$(tc-getAR)"
+ popd
+}
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+
+ dobin src/native/unix/jsvc
+}