summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 08:17:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:26 +0100
commit792608b975fa359d582e182e78d061240abcc9d2 (patch)
tree11b2f87f5582b4afc6c16a66ecd2a855997017b7
parentdev-python/pytest-trio: Bump to 0.8.0 (diff)
downloadgentoo-792608b9.tar.gz
gentoo-792608b9.tar.bz2
gentoo-792608b9.zip
dev-python/ansible-compat: Bump to 2.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.2.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 45851509af26..7c38274aeb1a 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,4 @@
DIST ansible-compat-2.2.0.tar.gz 38772 BLAKE2B dbe74d23d2f2e4275bd9df2303417ea83517e780e65c6a34bd6ae1022be265ac816b50b309fc45f88e0c7fac7d7a22c83a826cc15be050698a6f35b267a36ac3 SHA512 3bd199431659ecba52743c6c985d2cdc6ee55396444241ba2456bc5430bbc87e26087dffbfff62ac341fa854e19baa0d7052cf79f20511222fd9e001dd020136
DIST ansible-compat-2.2.1.tar.gz 39126 BLAKE2B c4d0512606c99ba8f07e0287620c94af6b46d7bf0077f12dcbfd9689fc7106f164a87db25de1625249ac2930858bfa655bd93d83aba0d85ed4f8bdd42cd345dc SHA512 3e941eb2c5303f83b7e7c057d08801f192889b636d9c6e56a2ac21cf75144a52ba2916eaedeba7bf848dd268387bf4d3261541d75145b213cc3f6baca6a06e5e
DIST ansible-compat-2.2.3.tar.gz 39603 BLAKE2B 16b88a1c669a74d858e4d47539811b33db77561f7e72088d5eece67ee1594e65a9328277bc65b96dce726180c29118b2b240b45541b6548b34584d643f836894 SHA512 4944ff97524734c445438c052aeedd0d526b58e91a56e0bcc32123fb3a9464c82f7718ea1897a09ef0dd33dfa36abdc6e0a0157e9a4eb8d341cbd712b2f538d1
+DIST ansible-compat-2.2.4.tar.gz 39772 BLAKE2B a4874675086956e11de4df4068e3b17b65b4f9f7610bb88bfba308d880fe478e39a4450a362bb06a555a36a41731f336c51756893ebe65715fc022421c51a293 SHA512 ec30329b2aa07ea7685a8cd91438f0d0e9003644fb3d15a842277abc7f5f1eeed61bb606ca594d6496e1980be0109dd5e4021bc4aeb66d909a312bf02649a1b9
diff --git a/dev-python/ansible-compat/ansible-compat-2.2.4.ebuild b/dev-python/ansible-compat/ansible-compat-2.2.4.ebuild
new file mode 100644
index 000000000000..12d9c5e19884
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+distutils_enable_tests pytest