summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-26 19:30:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 19:30:09 +0200
commit7935d39ec4bcd3b38bf35881c7bb52bd0f737466 (patch)
treebc7c4be42375bd8f8bbec3a478d3f31e94052d30
parentdev-python/roman: Enable py3.12 (diff)
downloadgentoo-7935d39ec4bcd3b38bf35881c7bb52bd0f737466.tar.gz
gentoo-7935d39ec4bcd3b38bf35881c7bb52bd0f737466.tar.bz2
gentoo-7935d39ec4bcd3b38bf35881c7bb52bd0f737466.zip
dev-python/fitsio: Bump to 1.1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fitsio/Manifest1
-rw-r--r--dev-python/fitsio/fitsio-1.1.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
index b236bdca4c69..3223a1a87139 100644
--- a/dev-python/fitsio/Manifest
+++ b/dev-python/fitsio/Manifest
@@ -1 +1,2 @@
DIST fitsio-1.1.8.gh.tar.gz 5052021 BLAKE2B fd54450ccce61a502b803e85df92821a0f64c91e6c8a535b09da6d6e68df1a0299ffc57e87b514d46f635d83dbabc15dc67a99d84fc93ca11ba052fab9472210 SHA512 8ff7c675d39c74ae821dde29ebbfaa5686a4c8e4454bf6ec4b7edce2f6a2e026aa3fac584af1647e7913748202c8c8e3d58deba9bf07253e3fe4606fd2b52c93
+DIST fitsio-1.1.9.gh.tar.gz 5052730 BLAKE2B 4169eed73e825f37bc5f5e6a2b27942b08f14d0e38c8037aa094031cd1b85e60ba3be8499c7d1225e78c093581aafe681177e4acb7da553bda2b0992ea38d6f2 SHA512 9840e9e48a11d454bd02cf19167ba977fa624842172ac538c7d9c5a446fbe0ef6fa7ee146f3878232e5b35570b2eec731e597503346adcfab38a1d0bada2b463
diff --git a/dev-python/fitsio/fitsio-1.1.9.ebuild b/dev-python/fitsio/fitsio-1.1.9.ebuild
new file mode 100644
index 000000000000..aae8b9bbdd5a
--- /dev/null
+++ b/dev-python/fitsio/fitsio-1.1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="
+ https://github.com/esheldon/fitsio/
+ https://pypi.org/project/fitsio/
+"
+SRC_URI="
+ https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ use_system_fitsio = True
+ EOF
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest
+}