summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-29 01:18:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-29 01:28:24 -0400
commit7943e2bcc08484d66e982da0c73792b766cc5c95 (patch)
treec696d1c9c50275a00aa2a2ab9a75971f08a776c6
parentmedia-libs/volpack: EAPI7->8, use https, drop static-libs (diff)
downloadgentoo-7943e2bc.tar.gz
gentoo-7943e2bc.tar.bz2
gentoo-7943e2bc.zip
media-libs/volpack: fix build with clang16 by not building examples
These were installed (full with .libs/* and .o files) in /usr/share, /and/ also failed with clang16. Unfortunately by not fixing the sources they will continue to be poor examples for all. Closes: https://bugs.gentoo.org/870706 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch16
-rw-r--r--media-libs/volpack/volpack-1.0_p7-r2.ebuild4
2 files changed, 20 insertions, 0 deletions
diff --git a/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch b/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
new file mode 100644
index 000000000000..1476f23084f5
--- /dev/null
+++ b/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
@@ -0,0 +1,16 @@
+Building these is broken with clang16 and they are primarily
+intended to be looked rather rather than built.
+
+https://bugs.gentoo.org/870706
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,3 +7,2 @@
+ man \
+- examples \
+ doc
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -196,3 +196,2 @@
+ man \
+- examples \
+ doc
diff --git a/media-libs/volpack/volpack-1.0_p7-r2.ebuild b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
index 52cab1b988bf..f7076c8c6c31 100644
--- a/media-libs/volpack/volpack-1.0_p7-r2.ebuild
+++ b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
@@ -17,6 +17,10 @@ IUSE="doc examples"
BDEPEND="sys-devel/m4"
+PATCHES=(
+ "${FILESDIR}"/${P}-skip-examples.patch
+)
+
src_compile() {
emake -j1
}