summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-02 07:41:50 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-02 08:05:53 +0100
commit79634f748613da3b27ea9d31ab60463832a61428 (patch)
treea9e2c6f0797ccb9fbdfcf4cf4b07e3f464ae9cfb
parentsys-apps/pcsc-tools: add 1.7.1 (diff)
downloadgentoo-79634f748613da3b27ea9d31ab60463832a61428.tar.gz
gentoo-79634f748613da3b27ea9d31ab60463832a61428.tar.bz2
gentoo-79634f748613da3b27ea9d31ab60463832a61428.zip
dev-ruby/tty-prompt: update EAPI 7 -> 8, add ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/tty-prompt/tty-prompt-0.23.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.23.1-r1.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.23.1-r1.ebuild
new file mode 100644
index 000000000000..cdefde250a22
--- /dev/null
+++ b/dev-ruby/tty-prompt/tty-prompt-0.23.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-prompt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A beautiful and powerful interactive command line prompt"
+HOMEPAGE="https://github.com/piotrmurach/tty-prompt"
+SRC_URI="https://github.com/piotrmurach/tty-prompt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/pastel-0.8:0
+ >=dev-ruby/tty-reader-0.8:0
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}