summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-01-21 16:57:47 -0500
committerCraig Andrews <candrews@gentoo.org>2024-01-21 16:59:56 -0500
commit7976993643a7f55cddc70703d19e5c1aa21996c1 (patch)
tree8ad3ac561d9b18064c55e012e315ceba406c9fc1
parentwww-apps/prowlarr: drop 1.12.2.4211 (diff)
downloadgentoo-79769936.tar.gz
gentoo-79769936.tar.bz2
gentoo-79769936.zip
net-libs/ngtcp2: add 1.2.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/ngtcp2-1.2.0.ebuild52
-rw-r--r--net-libs/ngtcp2/ngtcp2-9999.ebuild4
3 files changed, 55 insertions, 2 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index e1f2c1c77af6..7c27d0c90bf5 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -1,2 +1,3 @@
DIST ngtcp2-0.14.1.tar.xz 585788 BLAKE2B 68574767c701432e7558fa85cbad0d49934d220e292ceb82cdf19a715f247c6ec9b3a2b87def1176ade067a78c84bd3495936847a9a53fcadaff7b66971eca8d SHA512 52c55bc322d979d020ab3124a7cc0033d0f3e5649e3c8ee5f00aa64dbad83c4f199d50685704cc9372821e7fc81c59eea79f33894260b5dca171712d5b3899a0
DIST ngtcp2-1.1.0.tar.xz 595536 BLAKE2B df37cede58fe67e9121d3c985a6d26b3534a2ef2805a9fb0ee92369d87e849164916e36c23b0e3055b4fa817307b1aa47cc1c0bfe3b03690401f00c0f050b9e8 SHA512 0de7d1aa67a5dbbf718313f90b7535980d29902a3d7e7a8a5e0362ec54b5ffe00ec2e844262ab05ddf6a0f3a1acc716a9b6df181121f8c3b66e138a91cfbe067
+DIST ngtcp2-1.2.0.tar.xz 598000 BLAKE2B 7594817c3a26a41f8d32145d81be6060f51830d671b6bfea40c400be6fda75cb0b61b78bb58d6773dcc369ecd977d9f9e871ed5a9b90e80021e11545bec240ab SHA512 98a5724df82340d9448e0d11393bf9638aeb766edcae67255fb421538fba05e01f56fd16b85b157b21ff086696508f2d9ca410e81b8495411afcce77325c241a
diff --git a/net-libs/ngtcp2/ngtcp2-1.2.0.ebuild b/net-libs/ngtcp2/ngtcp2-1.2.0.ebuild
new file mode 100644
index 000000000000..1f15a2e28c49
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-1.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl static-libs test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DENABLE_BORINGSSL=OFF
+ -DENABLE_PICOTLS=OFF
+ -DENABLE_WOLFSSL=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/ngtcp2/ngtcp2-9999.ebuild b/net-libs/ngtcp2/ngtcp2-9999.ebuild
index 4d3a4cbaa377..1f15a2e28c49 100644
--- a/net-libs/ngtcp2/ngtcp2-9999.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~hppa ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
fi
DESCRIPTION="Implementation of the IETF QUIC Protocol"