summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-30 10:50:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-30 11:22:46 +0300
commit7982b888858d05f6c6b46ab825cce0b53c2aa41e (patch)
tree8095b44c435405c18702ca21dabd628f175b06a5
parentdev-python/snakeoil: add 0.10.1 (diff)
downloadgentoo-7982b888858d05f6c6b46ab825cce0b53c2aa41e.tar.gz
gentoo-7982b888858d05f6c6b46ab825cce0b53c2aa41e.tar.bz2
gentoo-7982b888858d05f6c6b46ab825cce0b53c2aa41e.zip
dev-python/nest_asyncio: add 1.5.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/nest_asyncio/Manifest1
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.6.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
index 1853145ed30a..4889e03c81b6 100644
--- a/dev-python/nest_asyncio/Manifest
+++ b/dev-python/nest_asyncio/Manifest
@@ -1 +1,2 @@
DIST nest_asyncio-1.5.5.tar.gz 7386 BLAKE2B c5d3704dae962ec82a515e2c056c24bd0fbabcf1cd2347379e1d58fc23c922325c89ed0941aead4dc90e0a94fc39ddb5e38fe4decc6e444b0c1261ae955520cb SHA512 8f28b4495f1d595f5943fb8a40c8894183398865059c42686483d6c4af6634b5119ff6e694b98662bfdd71046ec0bed70f5fcceb67971637c0fed91cb6d6eaea
+DIST nest_asyncio-1.5.6.tar.gz 7444 BLAKE2B 04b5808b3187c1155c440c903f0e1d5593f49204e6ffea2a37dc2b6112a365b94ab80823ce512a4cdf6c0799ef1c18d55fc0a841030a2cb93e0913fdf770f247 SHA512 9672cdd72b2bad7c968fa23c94e8bf8014aabf0aefd79b260503e7fe640cb7649f5c266133a4eb87aedcd99cea644fa51f8cd09d789777aca11eb64e84cf4ca5
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.6.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.6.ebuild
new file mode 100644
index 000000000000..3227cbb79d8d
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.5.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest