summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2022-06-02 07:36:39 +0200
committerFabian Groffen <grobian@gentoo.org>2022-06-06 15:12:02 +0200
commit799401bea340239aa253d4d6ed3a10f786183b6b (patch)
tree78c9d81014a1708025e800a71593022420fae171
parentapp-arch/advancecomp: Remove old (diff)
downloadgentoo-799401be.tar.gz
gentoo-799401be.tar.bz2
gentoo-799401be.zip
dev-python/carbon: bump 1.1.10
Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--dev-python/carbon/Manifest1
-rw-r--r--dev-python/carbon/carbon-1.1.10.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
index 538ec9058f80..b6548c3067d2 100644
--- a/dev-python/carbon/Manifest
+++ b/dev-python/carbon/Manifest
@@ -1 +1,2 @@
+DIST carbon-1.1.10.tar.gz 77091 BLAKE2B 367beb81a4dcf4c5fff6bf9884c7accb8aea9daa88d6d890bb977c926268b7ae041c9ac8e4b537f07d08d6c970f536ccc87ae6b4caef555883aadeab155fedce SHA512 a5c8d730e311bb65682c701b79a5e3e02e35eec5c0d923fece3f63d7036ca1f85775100fba9a2090487f2cf75bae7708dae9580deccd8fc586f2820b03e14b4c
DIST carbon-1.1.8.tar.gz 72452 BLAKE2B d76a281925645ebf6f74ff83f8ea6a52016f29ae0e35143e48e9aa0f2fcc267ceee1b5040ad756bbab8b2c1ffde5040231b8e0b581bd177bfb31ddf33fab7933 SHA512 b679d0329a5c8701af8aad3bdc51d64fbab7d05214c09368a218f1c925593002596a04b50fd2aadf26bd21ea7ef4b8262ae7f8169ef0d6ee40dccbc933539161
diff --git a/dev-python/carbon/carbon-1.1.10.ebuild b/dev-python/carbon/carbon-1.1.10.ebuild
new file mode 100644
index 000000000000..52f67e9dfa62
--- /dev/null
+++ b/dev-python/carbon/carbon-1.1.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend data caching and persistence daemon for Graphite"
+HOMEPAGE="https://graphiteapp.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+# whisper appears to have been missed from listing in install_requires in setup.py
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Do not install the configuration and data files. We install them
+ # somewhere sensible by hand.
+ sed -i -e '/data_files=install_files,/d' setup.py || die
+ # We want FHS-style paths instead of /opt/graphite
+ export GRAPHITE_NO_PREFIX=yes
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/carbon
+ doins conf/*
+
+ keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
+
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
+
+ newconfd "${FILESDIR}"/carbon.confd carbon-cache
+ newconfd "${FILESDIR}"/carbon.confd carbon-relay
+ newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
+}
+
+pkg_postinst() {
+ einfo 'This ebuild installs carbon into FHS-style paths.'
+ einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
+ einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
+ einfo '(see /etc/carbon/carbon.conf.example).'
+ einfo ' '
+ einfo 'OpenRC init script supports multiple instances !'
+ einfo 'Example to run an instance b of carbon-cache :'
+ einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
+ einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
+}