summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 17:24:51 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 17:26:40 +0200
commit799e36433a847d3fd98c32f3de67576ecf22dcfd (patch)
treef46cf6716e49422429195c8db40d2a165ce6a924
parentsys-apps/dbus-broker: fix build with USE="apparmor -audit" (diff)
downloadgentoo-799e3643.tar.gz
gentoo-799e3643.tar.bz2
gentoo-799e3643.zip
dev-python/oct2py: add 5.5.1, enable py3.10
Closes: https://bugs.gentoo.org/743589 Closes: https://bugs.gentoo.org/845768 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/oct2py/Manifest1
-rw-r--r--dev-python/oct2py/oct2py-5.5.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
index 2c0627be5fd8..ce03848ed007 100644
--- a/dev-python/oct2py/Manifest
+++ b/dev-python/oct2py/Manifest
@@ -1 +1,2 @@
DIST oct2py-5.2.0.tar.gz 436128 BLAKE2B 674bd034a44aa9cdb5fd4258c96665fda1b1d79a13ae9fa8d36d168e39385a978ed75bf8748ecdd53f57720785ea8e6c5ffd85d81f3b3c307a748fbc8d328a86 SHA512 55c2ee68b4fd73a8901fa2f7f67fefde5fa37d5070434aee03bfa2a746ff5179f51ccb96541a112e416438eb912caa81e040a5a1cbcbfac36b0285d496ac96fd
+DIST oct2py-5.5.1.tar.gz 442518 BLAKE2B c0a645464b64d04137f53f3c15bcd90d1df193d7dd7e955cf1e90b5d279091cc16b3052321a1788b6a382ad8759db1619b0a20d117c627d88abe75d13aeb62e3 SHA512 4bd81fc493d9c0b602bf254f7f8bcf5d2024c5c1004fd8a26d94608eb0c802af44d74efb2f2ff941cff89be5265136d987e9a8fc9c4ab987da513d57b291ad2e
diff --git a/dev-python/oct2py/oct2py-5.5.1.ebuild b/dev-python/oct2py/oct2py-5.5.1.ebuild
new file mode 100644
index 000000000000..4c4055e2f6f3
--- /dev/null
+++ b/dev-python/oct2py/oct2py-5.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
+ >=dev-python/octave_kernel-0.34.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.17[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )"
+
+EPYTEST_DESELECT=(
+ # No graphics toolkit available: 743589
+ "oct2py/ipython/tests/test_octavemagic.py::OctaveMagicTest::test_octave_plot"
+)
+
+distutils_enable_sphinx docs/source \
+ dev-python/numpydoc dev-python/sphinx-bootstrap-theme dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-5.2.0-mask-pkg-load-test.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}