summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-23 23:13:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-23 23:17:08 +0200
commit79a0f3bf2fee3e377f75bb28a2e0110ef9aad2e1 (patch)
tree27ce31c1413abb74a76c32451d85ac0c569b550a
parentprofiles: clang: allow glibc-2.35-r10 on stable already (diff)
downloadgentoo-79a0f3bf2fee3e377f75bb28a2e0110ef9aad2e1.tar.gz
gentoo-79a0f3bf2fee3e377f75bb28a2e0110ef9aad2e1.tar.bz2
gentoo-79a0f3bf2fee3e377f75bb28a2e0110ef9aad2e1.zip
sys-apps/razer-cli: new package; add version 2.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sys-apps/razer-cli/Manifest1
-rw-r--r--sys-apps/razer-cli/files/razer-cli-setup.patch9
-rw-r--r--sys-apps/razer-cli/metadata.xml20
-rw-r--r--sys-apps/razer-cli/razer-cli-2.1.0.ebuild37
4 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/razer-cli/Manifest b/sys-apps/razer-cli/Manifest
new file mode 100644
index 000000000000..07441f8ebf2d
--- /dev/null
+++ b/sys-apps/razer-cli/Manifest
@@ -0,0 +1 @@
+DIST razer-cli-2.1.0.gh.tar.gz 6985414 BLAKE2B 817a53061d1174fb0b0ae50e645c6b9796599760459523455dd4ee20e07f00389c2eaad41c81f08d1dba5eec6a9712dbf2c5c449d3671726c2b2cf0ddb3c0b8e SHA512 d29cb334673f9ae20b9a322f5af86ce9355392a63d9444d7ac46b0f3fd80af63b5e4bf12644897f3eefa76a5f1fa81dcdaf091dc978f00552b01d14813ff19fd
diff --git a/sys-apps/razer-cli/files/razer-cli-setup.patch b/sys-apps/razer-cli/files/razer-cli-setup.patch
new file mode 100644
index 000000000000..de0aee5cc68b
--- /dev/null
+++ b/sys-apps/razer-cli/files/razer-cli-setup.patch
@@ -0,0 +1,9 @@
+--- a/setup.py
++++ b/setup.py
+@@ -20,6 +20,4 @@ setup(
+ packages=find_packages(),
+ entry_points={"console_scripts": ["razer-cli=razer_cli.razer_cli.main:main"]},
+ python_requires=">=3.6",
+- package_data={'': ['razer_cli/razer_cli/man_pages']},
+- include_package_data=True,
+ )
diff --git a/sys-apps/razer-cli/metadata.xml b/sys-apps/razer-cli/metadata.xml
new file mode 100644
index 000000000000..46f8e78aef64
--- /dev/null
+++ b/sys-apps/razer-cli/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ With this command line interface you can configure your Razer peripherals,
+ such as keyboard and mouse, set their colors and effects, etc. The most
+ simple use case (for which this tool was originally developed) is to use it
+ in symbiosis with pywal. Then this tool will set your Razer colors to
+ Pywal's colors.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/LoLei/razer-cli/-/issues/</bugs-to>
+ <remote-id type="gitlab">LoLei/razer-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/razer-cli/razer-cli-2.1.0.ebuild b/sys-apps/razer-cli/razer-cli-2.1.0.ebuild
new file mode 100644
index 000000000000..b886d06eb6cb
--- /dev/null
+++ b/sys-apps/razer-cli/razer-cli-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Command line interface for controlling Razer devices on Linux"
+HOMEPAGE="https://github.com/LoLei/razer-cli/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LoLei/${PN}.git"
+else
+ SRC_URI="https://github.com/LoLei/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ sys-apps/openrazer[client,daemon,${PYTHON_USEDEP}]
+ x11-apps/xrdb
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+
+distutils_enable_tests unittest
+
+src_test() {
+ virtx distutils-r1_src_test
+}