summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 00:27:22 +0100
committerSam James <sam@gentoo.org>2022-04-07 00:33:48 +0100
commit79a1bc12624677b5cc5aed14cd17627180b5c507 (patch)
tree8ee1c43938360ad27633ebf92a115bd62c572134
parentapp-arch/lziprecover: add verify-sig (diff)
downloadgentoo-79a1bc12.tar.gz
gentoo-79a1bc12.tar.bz2
gentoo-79a1bc12.zip
app-arch/lunzip: add verify-sig
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/lunzip/Manifest1
-rw-r--r--app-arch/lunzip/lunzip-1.13.ebuild6
2 files changed, 6 insertions, 1 deletions
diff --git a/app-arch/lunzip/Manifest b/app-arch/lunzip/Manifest
index c52d5b73ad65..022bb8ea530b 100644
--- a/app-arch/lunzip/Manifest
+++ b/app-arch/lunzip/Manifest
@@ -1 +1,2 @@
DIST lunzip-1.13.tar.gz 66541 BLAKE2B 45b6a4ffaac6d9b8ddeeebe5e33609bf4e671ad7370570035bacf41ee8ad35f49e14f495dfba650de284fedca1a63ebafe7f67c18083b4add94caaf7709d8e2b SHA512 67f950883b7062d37601bc16d7d64c07f6c580afbf3c0f61394dd6fb5d41c27214484b1dea7aabd41db06d18162b95b5734674646c4fcc833268cabe8cba91bb
+DIST lunzip-1.13.tar.gz.sig 72 BLAKE2B a0d852dbb5394c5fb3e287cf4111290e0c603414de5a00a2d6173821df2410e4d826554ba4e04b5e9b7df0fa247cd95335a1a227b7cf38d4c5a7f3cc436be6ef SHA512 b71a73e7ad3a25140343db92c0ccf6311d0a30c71675e01a36da4735d0e0523d12d32b6472409359345ad6c9e550dccd399442d98fde44593af42f516119b3fb
diff --git a/app-arch/lunzip/lunzip-1.13.ebuild b/app-arch/lunzip/lunzip-1.13.ebuild
index 4f7d48dab0be..3106eed819d3 100644
--- a/app-arch/lunzip/lunzip-1.13.ebuild
+++ b/app-arch/lunzip/lunzip-1.13.ebuild
@@ -3,16 +3,20 @@
EAPI=8
-inherit toolchain-funcs
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/antoniodiazdiaz.asc
+inherit toolchain-funcs verify-sig
DESCRIPTION="Decompressor for the lzip format, written in C"
HOMEPAGE="https://www.nongnu.org/lzip/lunzip.html"
SRC_URI="https://download.savannah.gnu.org/releases/lzip/lunzip/${P}.tar.gz"
+SRC_URI+=" verify-sig? ( https://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz.sig )"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-antoniodiazdiaz )"
+
src_configure() {
# not autotools-based
local myconf=(