summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-25 07:02:15 +0000
committerSam James <sam@gentoo.org>2023-11-25 08:36:55 +0000
commit79b6097b68752e2763eaca4583efd27abb5bf4fd (patch)
treedb4d3d600c525f2bd9f17b268a04a33d0c33564c
parentdev-db/etcd: add 3.5.10 (diff)
downloadgentoo-79b6097b68752e2763eaca4583efd27abb5bf4fd.tar.gz
gentoo-79b6097b68752e2763eaca4583efd27abb5bf4fd.tar.bz2
gentoo-79b6097b68752e2763eaca4583efd27abb5bf4fd.zip
app-forensics/aflplusplus: drop 4.06c-r2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-forensics/aflplusplus/Manifest2
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.06c-r2.ebuild89
2 files changed, 0 insertions, 91 deletions
diff --git a/app-forensics/aflplusplus/Manifest b/app-forensics/aflplusplus/Manifest
index d97648b84c54..802e3724f442 100644
--- a/app-forensics/aflplusplus/Manifest
+++ b/app-forensics/aflplusplus/Manifest
@@ -1,4 +1,2 @@
-DIST aflplusplus-4.06c-patches.tar.xz 4360 BLAKE2B fb59065ef610e87d8bc822513822c150b592e0cdcf4f8f2d861b5dc4a5ded49a03b4ccc46636e24d69bdcee58f6882511f25a04cbc02565f9435c47be1b0829f SHA512 251db964ce6c7e1f59c6c1a8383c1fe4d362c7d336df4d13f0bc1f3c8583494e2b9c9f160fdd544174cc784afc1ae100310109d0d6a30c361b82f3ab50350afa
-DIST aflplusplus-4.06c.tar.gz 2859398 BLAKE2B bf26d6be364d01f91a5b60e2bca1ab48e2fed04571bbaee2fd74c31af1c3d53295808c5372bda8dc941232349e9113e09f2d0e8cadc5917fc4fc52e24bad9d60 SHA512 b585b244218e70e1120a81a5fbb7401d277174be13c5d5d507130ff7a7b25723ff29c2b3c820466ba847ff53ef016b23781edaccdfcdce904f6b93ec4d860140
DIST aflplusplus-4.07c-patches.tar.xz 4788 BLAKE2B de109198fbabfce2554459fee6a14f66002a952f5584ff265a6ff7d7646f520ed53a6d9c8c125a05eb5a4aa0c1cc675dca82647ad4c0965cdab10d3aa2f09467 SHA512 0ea4279b261d55cf209e32ca4b7fd7dc1181ec902dd7e4c7f36854d84f14037e643a543dcbb849927b41919c527303fc5877c9fab5b09c8988fbfab499b8f8bc
DIST aflplusplus-4.07c.tar.gz 2878659 BLAKE2B c3c4c5507e29ed8015784378a13a55cb6b389dec915979749b1869496c16366ce876f1eecc91eb09d51cc58266a92296218cd5eda2a201f5cf4faaa2ea61942f SHA512 c62fce112d59ef5ffb847adab9a7ff8486d44e6316a391392979da19a8160b55f9af7f75fd39cdc98997b3e166f4f6a33ddf31b827c9414a1392657701ecb5e8
diff --git a/app-forensics/aflplusplus/aflplusplus-4.06c-r2.ebuild b/app-forensics/aflplusplus/aflplusplus-4.06c-r2.ebuild
deleted file mode 100644
index 8c9982b8702c..000000000000
--- a/app-forensics/aflplusplus/aflplusplus-4.06c-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-LLVM_MAX_SLOT=16
-inherit toolchain-funcs llvm optfeature python-single-r1
-
-AFL_PATCHSET="${PN}-4.06c-patches"
-DESCRIPTION="A fork of AFL, the popular compile-time instrumentation fuzzer"
-HOMEPAGE="https://github.com/AFLplusplus/AFLplusplus"
-SRC_URI="https://github.com/AFLplusplus/AFLplusplus/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${AFL_PATCHSET}.tar.xz"
-S="${WORKDIR}"/AFLplusplus-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64"
-IUSE="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Tests involve heavy use of LD_PRELOAD in some cases
-# This isn't compatible with sandbox
-RESTRICT="test"
-
-RDEPEND="
- ${PYTHON_DEPS}
- <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):=
- || (
- sys-devel/clang:14
- sys-devel/clang:15
- sys-devel/clang:${LLVM_MAX_SLOT}
- )
- !app-forensics/afl"
-DEPEND="
- ${RDEPEND}
- test? ( dev-util/cmocka )
-"
-
-QA_FLAGS_IGNORED="afl-gcc-cmplog-pass.so afl-gcc-cmptrs-pass.so"
-QA_PREBUILT="usr/share/afl/testcases/others/elf/small_exec.elf"
-
-PATCHES=(
- "${WORKDIR}"/${AFL_PATCHSET}
-)
-
-llvm_check_deps() {
- has_version -b "sys-devel/clang:${LLVM_SLOT}" && \
- has_version -b "sys-devel/llvm:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- python-single-r1_pkg_setup
-}
-
-mymake() {
- emake \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CFLAGS_FLTO="" \
- LLVM_CONFIG="$(get_llvm_prefix ${LLVM_MAX_SLOT})"/bin/llvm-config \
- PREFIX="${EPREFIX}/usr" \
- HELPER_PATH="${EPREFIX}/usr/$(get_libdir)/afl" \
- DOC_PATH="${EPREFIX}/usr/share/doc/${PF}" \
- MAN_PATH="${EPREFIX}/usr/share/man/man8" \
- "$@"
-}
-
-src_compile() {
- mymake
-}
-
-src_test() {
- mymake test
-}
-
-src_install() {
- mymake DESTDIR="${D}" install
- dostrip -x /usr/share/afl/testcases/
-}
-
-pkg_postinst() {
- # TODO: Any others?
- optfeature "fuzzing with AFL_USE_ASAN" sys-libs/compiler-rt-sanitizers[asan]
- optfeature "fuzzing with AFL_USE_MSAN" sys-libs/compiler-rt-sanitizers[msan]
-}