summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 19:19:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-01 19:47:37 +0100
commit79ba50f3e692f57b7ee9d4dc8af935f5e851a5a1 (patch)
tree15220e1256af9d561a3776dc65237906ac2432b0
parentdev-ml/menhir: add ocamlbuild dep (diff)
downloadgentoo-79ba50f3.tar.gz
gentoo-79ba50f3.tar.bz2
gentoo-79ba50f3.zip
dev-ml/js_of_ocaml: remove old
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/js_of_ocaml/Manifest1
-rw-r--r--dev-ml/js_of_ocaml/files/tyxml36-2.patch30
-rw-r--r--dev-ml/js_of_ocaml/files/tyxml36.patch158
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild52
4 files changed, 0 insertions, 241 deletions
diff --git a/dev-ml/js_of_ocaml/Manifest b/dev-ml/js_of_ocaml/Manifest
index fa92aea86b76..e312923d8a2c 100644
--- a/dev-ml/js_of_ocaml/Manifest
+++ b/dev-ml/js_of_ocaml/Manifest
@@ -1,2 +1 @@
-DIST js_of_ocaml-2.6.tar.gz 1291882 SHA256 c1f066d09524c6be2d40cfb387de49b337837dcc8f2f746a207f37706ca66460 SHA512 2c4e294b7946757d9b05ec640e130cbee6a0130c03eb3a2188988fb956c1f0e2738c32e97abc461e748e667e7d31e386c5470942df84ddbcf5903d41b133e8c8 WHIRLPOOL abf477caa49edc65b5e577a90dd86641f12b6757e6f2c9034fe08d51cc1ac11209b73e8fdd88de420ed0277d8715bb085c10d29b237854cdebb8a9e36f8e22fe
DIST js_of_ocaml-2.7.tar.gz 1304487 SHA256 52922f55428a1d8a55ec2493c4989152e06efd29a981adf8ac9f343f558854b5 SHA512 ab6e5d16342bf763c10eb5c2e7589610622034eee2ad82aa09c6f68448f155a5c56584702307852b251bde80146c1b7115ed6add1358ad96b130c9dd2b96118b WHIRLPOOL 278c17432fdf9bf670df33479c68705868be39eb4d53f67fc489fe44ac2e7645dd5e2ed3e6e71752a2387b516ce0ab6dc99ac1d870fc75ffdad9df87031e9de4
diff --git a/dev-ml/js_of_ocaml/files/tyxml36-2.patch b/dev-ml/js_of_ocaml/files/tyxml36-2.patch
deleted file mode 100644
index 0f7771c98604..000000000000
--- a/dev-ml/js_of_ocaml/files/tyxml36-2.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-commit f11959da5a630a7dca47497c9543231d9698b406
-Author: Vasilis Papavasileiou <git@vasilis.airpost.net>
-Date: Fri Aug 7 11:16:20 2015 +0200
-
- Tyxml_js: ft constructor in Xml_wrap (forward-compatibility)
-
-diff --git a/lib/tyxml/tyxml_js.ml b/lib/tyxml/tyxml_js.ml
-index 4799600..cdf7cd2 100644
---- a/lib/tyxml/tyxml_js.ml
-+++ b/lib/tyxml/tyxml_js.ml
-@@ -164,6 +164,7 @@ module Html5 = Html5_f.Make(Xml)(Svg)
- module Xml_wrap = struct
- type 'a t = 'a React.signal
- type 'a tlist = 'a ReactiveData.RList.t
-+ type ('a, 'b) ft = 'a -> 'b
- let return = React.S.const
- let fmap f = React.S.map f
- let nil () = ReactiveData.RList.nil
-diff --git a/lib/tyxml/tyxml_js.mli b/lib/tyxml/tyxml_js.mli
-index 8cb33c5..db2183e 100644
---- a/lib/tyxml/tyxml_js.mli
-+++ b/lib/tyxml/tyxml_js.mli
-@@ -50,6 +50,7 @@ module Xml : XML with module W = Xml_wrap.NoWrap
- module Xml_wrap : Xml_wrap.T
- with type 'a t = 'a React.signal
- and type 'a tlist = 'a ReactiveData.RList.t
-+ and type ('a, 'b) ft = 'a -> 'b
-
- module Util : sig
- val update_children : Dom.node Js.t -> Dom.node Js.t ReactiveData.RList.t -> unit
diff --git a/dev-ml/js_of_ocaml/files/tyxml36.patch b/dev-ml/js_of_ocaml/files/tyxml36.patch
deleted file mode 100644
index 34a2aabf87fc..000000000000
--- a/dev-ml/js_of_ocaml/files/tyxml36.patch
+++ /dev/null
@@ -1,158 +0,0 @@
-commit ebf7150f41c64ac0e18e9f89d1e565b6c3115414
-Author: Vasilis Papavasileiou <git@vasilis.airpost.net>
-Date: Thu Aug 6 11:52:11 2015 +0200
-
- up-to-date version of @drup's new-style wrapping (ocsigen/tyxml#58)
-
-diff --git a/lib/tyxml/tyxml_js.ml b/lib/tyxml/tyxml_js.ml
-index 0143219..4799600 100644
---- a/lib/tyxml/tyxml_js.ml
-+++ b/lib/tyxml/tyxml_js.ml
-@@ -20,8 +20,19 @@
- let js_string_of_float f = (Js.number_of_float f)##toString()
- let js_string_of_int i = (Js.number_of_float (float_of_int i))##toString()
-
-+
-+module type XML =
-+ Xml_sigs.T
-+ with type uri = string
-+ and type event_handler = Dom_html.event Js.t -> bool
-+ and type mouse_event_handler = Dom_html.mouseEvent Js.t -> bool
-+ and type keyboard_event_handler = Dom_html.keyboardEvent Js.t -> bool
-+ and type elt = Dom.node Js.t
-+
-+
- module Xml = struct
-
-+ module W = Xml_wrap.NoWrap
- type 'a wrap = 'a
- type 'a list_wrap = 'a list
-
-@@ -162,7 +173,6 @@ module Xml_wrap = struct
- let append x y = ReactiveData.RList.concat x y
- end
-
--
- module Util = struct
- open ReactiveData
- open RList
-@@ -226,9 +236,23 @@ end
-
-
- module R = struct
-- module Xml_wed = struct
-- type 'a wrap = 'a Xml_wrap.t
-- type 'a list_wrap = 'a Xml_wrap.tlist
-+
-+ let filter_attrib (name,a) on =
-+ match a with
-+ | Xml.Event _ ->
-+ raise (Invalid_argument "filter_attrib not implemented for event handler")
-+ | Xml.Attr a ->
-+ name,
-+ Xml.Attr
-+ (React.S.l2
-+ (fun on a -> if on then a else None) on a)
-+
-+ let attach_attribs = Xml.attach_attribs
-+
-+ module Xml = struct
-+ module W = Xml_wrap
-+ type 'a wrap = 'a W.t
-+ type 'a list_wrap = 'a W.tlist
- type uri = Xml.uri
- let string_of_uri = Xml.string_of_uri
- let uri_of_string = Xml.uri_of_string
-@@ -239,7 +263,7 @@ module R = struct
- type attrib = Xml.attrib
-
- let attr name f s =
-- let a = Xml_wrap.fmap f s in
-+ let a = W.fmap f s in
- name,Xml.Attr a
-
- let float_attrib name s = attr name (fun f -> Some (js_string_of_float f)) s
-@@ -267,7 +291,7 @@ module R = struct
- let leaf = Xml.leaf
- let node ?(a=[]) name l =
- let e = Dom_html.document##createElement(Js.string name) in
-- Xml.attach_attribs e a;
-+ attach_attribs e a;
- Util.update_children (e :> Dom.node Js.t) l;
- (e :> Dom.node Js.t)
- let cdata = Xml.cdata
-@@ -275,30 +299,22 @@ module R = struct
- let cdata_style = Xml.cdata_style
- end
-
-- module Xml_wed_svg = struct
-- include Xml_wed
-+ module Xml_Svg = struct
-+ include Xml
-
- let leaf = Xml_Svg.leaf
-
- let node ?(a = []) name l =
- let e =
- Dom_html.document##createElementNS(Dom_svg.xmlns,Js.string name) in
-- Xml.attach_attribs e a;
-+ attach_attribs e a;
- Util.update_children (e :> Dom.node Js.t) l;
- (e :> Dom.node Js.t)
- end
-
-- module Svg = Svg_f.MakeWrapped(Xml_wrap)(Xml_wed_svg)
-- module Html5 = Html5_f.MakeWrapped(Xml_wrap)(Xml_wed)(Svg)
-- let filter_attrib (name,a) on =
-- match a with
-- | Xml.Event _ ->
-- raise (Invalid_argument "filter_attrib not implemented for event handler")
-- | Xml.Attr a ->
-- name,
-- Xml.Attr
-- (React.S.l2
-- (fun on a -> if on then a else None) on a)
-+ module Svg = Svg_f.Make(Xml_Svg)
-+ module Html5 = Html5_f.Make(Xml)(Svg)
-+
- end
-
- module To_dom = Tyxml_cast.MakeTo(struct
-diff --git a/lib/tyxml/tyxml_js.mli b/lib/tyxml/tyxml_js.mli
-index b3323cc..8cb33c5 100644
---- a/lib/tyxml/tyxml_js.mli
-+++ b/lib/tyxml/tyxml_js.mli
-@@ -37,13 +37,16 @@
- @see <https://ocsigen.org/tyxml/dev/api/Html5_sigs.T> Html5_sigs.T to have a list of available functions to build HTML.
- *)
-
--module Xml : Xml_sigs.T
-+module type XML =
-+ Xml_sigs.T
- with type uri = string
- and type event_handler = Dom_html.event Js.t -> bool
- and type mouse_event_handler = Dom_html.mouseEvent Js.t -> bool
- and type keyboard_event_handler = Dom_html.keyboardEvent Js.t -> bool
- and type elt = Dom.node Js.t
-
-+module Xml : XML with module W = Xml_wrap.NoWrap
-+
- module Xml_wrap : Xml_wrap.T
- with type 'a t = 'a React.signal
- and type 'a tlist = 'a ReactiveData.RList.t
-@@ -57,10 +60,13 @@ module Svg : Svg_sigs.Make(Xml).T
- module Html5 : Html5_sigs.Make(Xml)(Svg).T
-
- module R : sig
-- module Svg : Svg_sigs.MakeWrapped(Xml_wrap)(Xml).T
-+ module Xml : XML with module W = Xml_wrap
-+
-+ module Svg : Svg_sigs.Make(Xml).T
- with type +'a elt = 'a Svg.elt
- and type +'a attrib = 'a Svg.attrib
-- module Html5 : Html5_sigs.MakeWrapped(Xml_wrap)(Xml)(Svg).T
-+
-+ module Html5 : Html5_sigs.Make(Xml)(Svg).T
- with type +'a elt = 'a Html5.elt
- and type +'a attrib = 'a Html5.attrib
- val filter_attrib : 'a Html5.attrib -> bool React.signal -> 'a Html5.attrib
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild
deleted file mode 100644
index b7fe9c9838fb..000000000000
--- a/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="A compiler from OCaml bytecode to javascript"
-HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
-SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="+ocamlopt doc +deriving"
-
-DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
- >=dev-ml/lwt-2.4.4:=
- dev-ml/react:=
- dev-ml/reactiveData:=
- >=dev-ml/tyxml-3.6:=
- dev-ml/cmdliner:=
- dev-ml/menhir:=
- dev-ml/ocaml-base64:=
- dev-ml/camlp4:=
- dev-ml/cppo:=
- deriving? ( >=dev-ml/deriving-0.6:= )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}/tyxml36.patch" \
- "${FILESDIR}/tyxml36-2.patch"
-}
-
-src_configure() {
- use ocamlopt || echo "BEST := byte" >> Makefile.conf
- use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
-}
-
-src_compile() {
- emake
- use doc && emake doc
-}
-
-src_install() {
- findlib_src_preinst
- emake BINDIR="${ED}/usr/bin/" install
- dodoc CHANGES README.md
- use doc && dohtml -r doc/api/html/
-}