summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-08-08 10:26:41 -0400
committerMatt Turner <mattst88@gentoo.org>2023-08-08 10:27:10 -0400
commit79d83cec69d93b015fb7c725cc74b4cf63bbab6e (patch)
tree402426e4bd15e611aed02380b6b170cf858633e8
parentgui-apps/gnome-console: Version bump to 44.4 (diff)
downloadgentoo-79d83cec69d93b015fb7c725cc74b4cf63bbab6e.tar.gz
gentoo-79d83cec69d93b015fb7c725cc74b4cf63bbab6e.tar.bz2
gentoo-79d83cec69d93b015fb7c725cc74b4cf63bbab6e.zip
dev-perl/Gtk2-Notify: Delete
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0-r1.ebuild41
-rw-r--r--dev-perl/Gtk2-Notify/Manifest1
-rw-r--r--dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch114
-rw-r--r--dev-perl/Gtk2-Notify/metadata.xml12
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 173 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0-r1.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0-r1.ebuild
deleted file mode 100644
index 1125d7e547d8..000000000000
--- a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.50.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=FLORA
-DIST_VERSION=0.05
-inherit perl-module virtualx
-
-DESCRIPTION="Perl interface to the notification library"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-perl/glib-perl
- dev-perl/Gtk2
- >=x11-libs/libnotify-0.7
-"
-BDEPEND="${RDEPEND}
- dev-perl/ExtUtils-Depends
- dev-perl/ExtUtils-PkgConfig
- test? ( dev-perl/Test-Exception )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.05-libnotify.patch )
-
-PERL_RM_FILES=( t/notification.t )
-# the test dies if no notification daemon is present...
-
-src_prepare() {
- sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
- die "Can't patch Makefile.PL for 5.26 dot-in-inc"
- perl-module_src_prepare
-}
-
-src_test() {
- # bug 416729
- virtx perl-module_src_test
-}
diff --git a/dev-perl/Gtk2-Notify/Manifest b/dev-perl/Gtk2-Notify/Manifest
deleted file mode 100644
index af5e52894c2f..000000000000
--- a/dev-perl/Gtk2-Notify/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Gtk2-Notify-0.05.tar.gz 60883 BLAKE2B 0910ade464356bb8070c5c68f1135396c5a55170673ed5a81634f2441ff55dea71507de3f5edfc2b6f12711140cc3d7764d8803b3d0c3a3a3a4440ae571f57ef SHA512 e6242c21f6a3345d990830798744c8dd3abf648c0110d395197fc74b185b68189f9fc90e0fc14717cc09505d67fbaf8f45c1b3fae65c873275537e55c9e35434
diff --git a/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
deleted file mode 100644
index 8865c1f3f1f0..000000000000
--- a/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-http://bugs.gentoo.org/398699
-http://rt.cpan.org/Public/Bug/Display.html?id=67297
-http://pkgs.fedoraproject.org/gitweb/?p=perl-Gtk2-Notify.git;a=blob_plain;f=libnotify.patch;hb=HEAD
-
---- a/t/notification.t
-+++ b/t/notification.t
-@@ -2,20 +2,18 @@
-
- use strict;
- use warnings;
--use Gtk2::TestHelper tests => 35;
-+use Gtk2::TestHelper tests => 32;
- use Test::Exception;
- use Gtk2::Notify -init, $0;
-
- ginterfaces_ok('Gtk2::Notify');
-
--my $w = Gtk2::Window->new;
--my $n = Gtk2::Notify->new('foo', 'bar', '', $w);
-+my $n = Gtk2::Notify->new('foo', 'bar', '');
-
- isa_ok($n, 'Gtk2::Notify');
-
- my @methods = qw(
- add_action
-- attach_to_widget
- clear_actions
- clear_hints
- close
-@@ -46,16 +44,6 @@ lives_ok(sub {
- }, 42);
- }, 'add_action');
-
--{
-- my $nw = Gtk2::Window->new;
-- lives_ok(sub {
-- $n->attach_to_widget($nw);
-- }, 'attach_to_widget');
-- lives_ok(sub {
-- $n->attach_to_widget($w);
-- }, 'attach_to_widget');
--}
--
- lives_ok(sub {
- $n->clear_actions;
- }, 'clear_actions with existing actions');
-@@ -99,8 +87,6 @@ lives_ok(sub {
- $n->close;
- }, 'close before show');
-
--$w->show_all;
--
- lives_ok(sub {
- $n->show;
- }, 'show');
---- a/xs/Notify.xs
-+++ b/xs/Notify.xs
-@@ -86,26 +86,12 @@ notify_get_server_info (class, OUTLIST c
- MODULE = Gtk2::Notify PACKAGE = Gtk2::Notify PREFIX = notify_notification_
-
- NotifyNotification *
--notify_notification_new (class, summary, body=NULL, icon=NULL, attach=NULL)
-+notify_notification_new (class, summary, body=NULL, icon=NULL)
- const gchar *summary
- const gchar *body
- const gchar *icon
-- GtkWidget_ornull *attach
- C_ARGS:
-- summary, body, icon, attach
--
--#if GTK_CHECK_VERSION (2, 9, 2)
--
--NotifyNotification *
--notify_notification_new_with_status_icon (class, summary, body=NULL, icon=NULL, status_icon=NULL)
-- const gchar *summary
-- const gchar *body
-- const gchar *icon
-- GtkStatusIcon *status_icon
-- C_ARGS:
-- summary, body, icon, status_icon
--
--#endif
-+ summary, body, icon
-
- gboolean
- notify_notification_update (notification, summary, message=NULL, icon=NULL)
-@@ -114,27 +100,6 @@ notify_notification_update (notification
- const gchar *message
- const gchar *icon
-
--void
--notify_notification_attach_to_widget (notification, attach)
-- NotifyNotification *notification
-- GtkWidget *attach
--
--#if GTK_CHECK_VERSION (2, 9, 2)
--
--void
--notify_notification_attach_to_status_icon (notification, status_icon)
-- NotifyNotification *notification
-- GtkStatusIcon *status_icon
--
--#endif
--
--void
--notify_notification_set_geometry_hints (notification, screen, x, y)
-- NotifyNotification *notification
-- GdkScreen *screen
-- gint x
-- gint y
--
- NO_OUTPUT gboolean
- notify_notification_show (notification)
- NotifyNotification *notification
diff --git a/dev-perl/Gtk2-Notify/metadata.xml b/dev-perl/Gtk2-Notify/metadata.xml
deleted file mode 100644
index 7bdfa2719222..000000000000
--- a/dev-perl/Gtk2-Notify/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>perl@gentoo.org</email>
- <name>Gentoo Perl Project</name>
- </maintainer>
- <upstream>
- <remote-id type="cpan">Gtk2-Notify</remote-id>
- <remote-id type="cpan-module">Gtk2::Notify</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 072611eff444..8ecf46281085 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -305,11 +305,6 @@ dev-ruby/c21e
dev-ruby/deprecated
# Matt Turner <mattst88@gentoo.org> (2023-07-06)
-# Dead package. No reverse dependencies.
-# Removal on 2023-08-06.
-dev-perl/Gtk2-Notify
-
-# Matt Turner <mattst88@gentoo.org> (2023-07-06)
# GNOME 45 mask
>=app-editors/gnome-text-editor-45_alpha
>=app-misc/gnote-45_alpha