summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 06:08:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:15 +0100
commit79efd6b13866b90e4b13d46fb072c98c3443191b (patch)
tree9d64e8e36a2325d80ead282d1685309fedd0170d
parentdev-python/cloudscraper: Bump to 1.2.68 (diff)
downloadgentoo-79efd6b1.tar.gz
gentoo-79efd6b1.tar.bz2
gentoo-79efd6b1.zip
dev-python/moto: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/metadata.xml2
-rw-r--r--dev-python/moto/moto-4.1.0.ebuild93
3 files changed, 95 insertions, 1 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 9b11b6cb189b..99d1d3db21ba 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -4,3 +4,4 @@ DIST moto-4.0.12.tar.gz 2559220 BLAKE2B 475097f498bc648d6a29db36343135372f088106
DIST moto-4.0.13.tar.gz 2563514 BLAKE2B 1d2f01ff0af7c1ab4bc8670015eeefddf70970aa321ca641989ef740bf3f896bacfeaf8b16cdf37b7fedecafa8d81cc3d66473315f867fcbd6143a7d010d9aba SHA512 1c5a6a19a5eccfd70de71ec0aaa7263f8a7ebb16f9576eb78d72b0a3f0dbdaa3e6db1a631ba36d5c1b04f6d8aded6f492cb8792da1e6fd036897a1dfbdca0b56
DIST moto-4.0.8.tar.gz 2488253 BLAKE2B ae707de8f0917b62904f38f977eded8f3e995271da8a7d6be47f05a24e3cb8bb8121e5e52625deb6c8f836e5f328352a7e6ea0855a4278c32dc9363da0faa8cc SHA512 9d3d3164bb6a77901bb55b8c536bfc8822e5b5292d79fedfe89a4a7fefaeab24b740d9a898e9487152a45c5a3bfd15d8aaca042a485bea389e1a82bb0a90bdd0
DIST moto-4.0.9.tar.gz 2496530 BLAKE2B 596dc00ce0c931d4405d1ad6fdfcff4acc5c7421b1f1d67f442e090249d3df81f89c570368b5e981ec49f14a35aed32621ff3dbedc7003e3c870f891e4eda20a SHA512 fedf2c97779a93b1ab3492122be5425f3d91219eb207cc21bf2822ffa52c6efe2c3c8ca233acafd02c725c46e77e883f8f941c29638bb3e32ffa774ed8a5ff69
+DIST moto-4.1.0.tar.gz 2561695 BLAKE2B ce95abe8d49bee64d5323988526e251c52cd5ee5df95fc058240336a2eb580bf7eafbef6b594328a4a5ef34d047a293656c8ec9cdbf9c41bf3c7df05fdfb33c5 SHA512 c5b234c7d7057922880ad9ba09bb4e0453ca09d9f2b58ffce1990092e5d5cb070954e9d6cca307730ecb5540509792d0dbb4135289137fc12469354a91f326b8
diff --git a/dev-python/moto/metadata.xml b/dev-python/moto/metadata.xml
index 7bc6dbe19ce4..52f3afd75b43 100644
--- a/dev-python/moto/metadata.xml
+++ b/dev-python/moto/metadata.xml
@@ -12,6 +12,6 @@
<!-- no allarches: package had portability problems before -->
<upstream>
<remote-id type="pypi">moto</remote-id>
- <remote-id type="github">spulec/moto</remote-id>
+ <remote-id type="github">getmoto/moto</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/moto/moto-4.1.0.ebuild b/dev-python/moto/moto-4.1.0.ebuild
new file mode 100644
index 000000000000..d49e38071fed
--- /dev/null
+++ b/dev-python/moto/moto-4.1.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ tests/test_appsync/test_server.py::test_appsync_list_tags_for_resource
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_s3/test_server.py::test_s3_server_post_to_bucket_redirect
+ tests/test_s3/test_multiple_accounts_server.py::TestAccountIdResolution::test_with_custom_request_header
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}