summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:06:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:58:53 -0600
commit79fcbafb38da003024e58eca0b7e916107d72113 (patch)
treed88ca622165299011deef1b181383ed0a3640a2f
parentdev-python/oslo-reports: 1.26.0 bup (diff)
downloadgentoo-79fcbafb.tar.gz
gentoo-79fcbafb.tar.bz2
gentoo-79fcbafb.zip
dev-python/oslo-versionedobjects: 1.31.2
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/oslo-versionedobjects/Manifest1
-rw-r--r--dev-python/oslo-versionedobjects/oslo-versionedobjects-1.31.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/oslo-versionedobjects/Manifest b/dev-python/oslo-versionedobjects/Manifest
index 0bb90444aacf..cb22e0be2efe 100644
--- a/dev-python/oslo-versionedobjects/Manifest
+++ b/dev-python/oslo-versionedobjects/Manifest
@@ -1 +1,2 @@
DIST oslo.versionedobjects-1.26.1.tar.gz 148214 BLAKE2B fa449b57db3ae4148fa431616b49b83d6a1424cc5f1845546fc945270bfa1b470f376a52edb0426f1fd86783cfe25906f476fab3417b3944c5f3074548704c77 SHA512 13962e9cfd5c63d9691bef0e1b31aa1751a506dc7a8aa3031612220778ba887d3122eea205456809bed9cec12c8fd5debfdce827d59ad8fc991ff85de7f841a1
+DIST oslo.versionedobjects-1.31.2.tar.gz 148160 BLAKE2B cb63e0607f4a9447618d287e3f2c252359832a0f4c7b60a22669da25ab90ebcdb8a97f2e10f61c759cba135329eb75be644809bd424e67ff1c6d61e612c45364 SHA512 a9d31a138e2f1e399e51b509c52c10c64acd783389b596032457c0fa74c112f5f6f67944ce88c88c35623f8d2d6612c09d04009d9014d0e9efc8f65b916d4ff3
diff --git a/dev-python/oslo-versionedobjects/oslo-versionedobjects-1.31.2.ebuild b/dev-python/oslo-versionedobjects/oslo-versionedobjects-1.31.2.ebuild
new file mode 100644
index 000000000000..5ee7581952a9
--- /dev/null
+++ b/dev-python/oslo-versionedobjects/oslo-versionedobjects-1.31.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that provides a generic versioned and RPC-friendly object model."
+HOMEPAGE="http://docs.openstack.org/developer/oslo.versionedobjects"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.versionedobjects/oslo.versionedobjects-${PV}.tar.gz"
+S="${WORKDIR}/oslo.versionedobjects-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]"