summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-23 22:37:44 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-23 22:37:59 +0100
commit7a117cca477e69fe0f14cbc352ae9a178ec21e27 (patch)
treea89ebccba14fe1ded92b87ca56dd0ce369e471ba
parentdev-lua/luafilesystem: update ebuild (diff)
downloadgentoo-7a117cca477e69fe0f14cbc352ae9a178ec21e27.tar.gz
gentoo-7a117cca477e69fe0f14cbc352ae9a178ec21e27.tar.bz2
gentoo-7a117cca477e69fe0f14cbc352ae9a178ec21e27.zip
dev-lua/luafilesystem: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.8.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-lua/luafilesystem/luafilesystem-1.8.0.ebuild b/dev-lua/luafilesystem/luafilesystem-1.8.0.ebuild
deleted file mode 100644
index 0fa2387e4829..000000000000
--- a/dev-lua/luafilesystem/luafilesystem-1.8.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-MY_PV=${PV//./_}
-
-DESCRIPTION="File System Library for the Lua Programming Language"
-HOMEPAGE="https://keplerproject.github.io/luafilesystem/"
-SRC_URI="https://github.com/keplerproject/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc luajit test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-lang/lua-5.1:*
- luajit? ( dev-lang/luajit:2 )"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_configure() {
- cat > config <<-EOF
- # Installation directories
-
- # Default installation prefix
- PREFIX="$($(tc-getPKG_CONFIG) --variable exec_prefix $(usex luajit 'luajit' 'lua'))"
-
- # System's libraries directory (where binary libraries are installed)
- LUA_LIBDIR="$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD $(usex luajit 'luajit' 'lua'))"
-
- # Lua includes directory
- LUA_INC=-I$(pwd)/src
- LUA_INC+=-I$($(tc-getPKG_CONFIG) --variable includedir $(usex luajit 'luajit' 'lua'))
-
- # OS dependent
- LIB_OPTION=\$(LDFLAGS) -shared
-
- LIBNAME=$T.so.$V
-
- # Compilation directives
- WARN=-O2 -Wall -fPIC -W -Waggregate-return -Wcast-align -Wmissing-prototypes -Wnested-externs -Wshadow -Wwrite-strings -pedantic
- INCS=\$(LUA_INC)
- CFLAGS+=\$(WARN) \$(INCS)
- CC=$(tc-getCC)
- EOF
-}
-
-src_test() {
- LUA_CPATH=./src/?.so $(usex luajit 'luajit' 'lua') tests/test.lua || die
-}
-
-src_install() {
- use doc && local HTML_DOCS=( doc/us/. )
- einstalldocs
-
- emake DESTDIR="${D}" install
-}