summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-07-15 20:28:45 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-08-11 09:11:47 +0300
commit7a163cfc269706c5fd015aa6327842b380203850 (patch)
tree379e80cbac1de6ba005647cebf1fc8e5ec695e33
parentdev-db/sqlmap: add 1.7.8 (diff)
downloadgentoo-7a163cfc269706c5fd015aa6327842b380203850.tar.gz
gentoo-7a163cfc269706c5fd015aa6327842b380203850.tar.bz2
gentoo-7a163cfc269706c5fd015aa6327842b380203850.zip
games-engines/fheroes2: add 1.0.6
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.0.6.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index a6c2ca02c945..11680cb1af94 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
DIST fheroes2-1.0.5.tar.gz 11570167 BLAKE2B 7294ae4a816ce0a42c035262cbc8d44fc53cfdaa1333934ac316607f7d086a44358fc13931e5dbce9b17ff65e58016efc57cd123747af30277bcf4c1bc195e1e SHA512 13f058319540fa9fa04955ff8a5f16a0113e791307d58c32025361c773757769306f632d2c6472ee6d0b704dc4c260a9c64954c19ba2e58ab21dc6744c3cdd3e
+DIST fheroes2-1.0.6.tar.gz 11611881 BLAKE2B b7219a1a843f4a08cfc9ade161e38b19dcb343fa6dc700568d2e38b984d2cd26c78d02b9792f7d893b0babcca7bf71a01d349bc3806136736d46768b048a8db2 SHA512 c42b2ded44b7d6e112de3e919044b6b7d69161cc8cf08198df88da42c7f77b2dcf9df9ea7b453def66902e85f42047c0375b093c8d2d91517acb42d1804e621b
diff --git a/games-engines/fheroes2/fheroes2-1.0.6.ebuild b/games-engines/fheroes2/fheroes2-1.0.6.ebuild
new file mode 100644
index 000000000000..f58beedc9f5c
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.0.6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ dev-lang/python
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ -DUSE_SYSTEM_LIBSMACKER=NO
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}