summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-17 21:20:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-17 21:26:26 +0100
commit7a2cba677fa09e4fdf68f3b4b7bac630fce054ab (patch)
tree7c88d6486da55dfc1a175867cbd2463ae6220207
parentdev-lang/mujs: remove old and vulnerable (diff)
downloadgentoo-7a2cba677fa09e4fdf68f3b4b7bac630fce054ab.tar.gz
gentoo-7a2cba677fa09e4fdf68f3b4b7bac630fce054ab.tar.bz2
gentoo-7a2cba677fa09e4fdf68f3b4b7bac630fce054ab.zip
media-libs/harfbuzz: Bump to version 2.1.3
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.1.3.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 982676bd5878..f62bb6e282a4 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -5,3 +5,4 @@ DIST harfbuzz-1.9.0.tar.bz2 3870586 BLAKE2B 53aa631145662fc0fa1bb80e6b438de7d68d
DIST harfbuzz-2.0.2.tar.bz2 4322171 BLAKE2B c844a623de5c2be7b6fb4a2cf0d38e689a6e639e25ece971646963acbdb10be05b82c4faea33688b1a3edfda4c3fe45b97e5ef87d7ca6d9776268b43ef23a7ee SHA512 4cb605c47617dd06d4a2e8ae01e44969f5addacee47ef5212442645c6229298d5080f85b0aca6a2fbedfd2007c679acad6a4b3e9389df1b3a6232bf6ef961577
DIST harfbuzz-2.1.0.tar.bz2 4375308 BLAKE2B c9581e4c6756e1c4e9cf82af9b078c7470fe07d3d2b3bc13e54c08b9007a2d9eb3ac3254462fca5843ab2b8f23b220b13226c5d4b67e80ccc487bc7d4e18ce7c SHA512 cf34ea5ace9f7ff0ef31768432bbbf3b66d909491cc571b4330c418df40be4fe57bf61bea60f94a4f76f25f687dd7f2401d46eae81c7b1d37f1e25295eb3d664
DIST harfbuzz-2.1.1.tar.bz2 4386396 BLAKE2B 9717a15fccc557b795cfd2462358b6659c57bd052976b2660b61d76a858b3df12b00ee8d824c30d4675261e2b30fb79ae3c14c98bfad3d5cfcc67fcd0b1ef44e SHA512 c3fc46eaeb8c02594e2430f853b6eebb762072638e3113e27ff9b5caefce2c06534e8056d57f35d87df6dbb1027cbc0c1a08f914dec7c6a715c3f0abc0a18933
+DIST harfbuzz-2.1.3.tar.bz2 4429069 BLAKE2B d00b5e4f83e9e4b8032cd4f0a8c00d3f88176118458026de69a68f1932bf437358dcd0ecea89f40a4f610816b1709f3b0784c9a619141fa459297754d934f42d SHA512 9bf5f7b857424037a3b3ea5c286e6ba8440c265fa663cf6b6c22cc08d36d84badfed8bdc46816ad982fc810677ebecccdb669ea98a021207e1858c8c355dbf19
diff --git a/media-libs/harfbuzz/harfbuzz-2.1.3.ebuild b/media-libs/harfbuzz/harfbuzz-2.1.3.ebuild
new file mode 100644
index 000000000000..85491d783cd9
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-2.1.3.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+if [[ ${PV} = 9999 ]] ; then
+ DEPEND+="
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+ "
+fi
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # bug 618772
+ append-cxxflags -std=c++14
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local myeconfargs=(
+ --without-coretext
+ --without-uniscribe
+ $(use_enable static-libs static)
+ $(multilib_native_use_with cairo)
+ $(use_with fontconfig)
+ $(use_with glib)
+ $(use_with introspection gobject)
+ $(use_with graphite graphite2)
+ $(use_with icu)
+ $(multilib_native_use_enable introspection)
+ $(use_with truetype freetype)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}