summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-09-15 13:12:23 +0200
committerPacho Ramos <pacho@gentoo.org>2019-09-15 13:43:42 +0200
commit7a2e860b019411c855e9effb8fcbf15ab9e9d35b (patch)
tree4372d0013e0437694a69bd5caf866ab9c84b9e4f
parentmedia-video/mkvtoolnix: Version bump to 37.0.0 (diff)
downloadgentoo-7a2e860b.tar.gz
gentoo-7a2e860b.tar.bz2
gentoo-7a2e860b.zip
media-gfx/eog-plugins: Bump to 3.36.4
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.26.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 0b5720f84ec2..e2ccf936dece 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-3.26.3.tar.xz 470712 BLAKE2B cd5845481006b681555f35d1f353ed624baa83fc8fc45bb889b2418f31a776bf9e08e270f911f61f431123825a5b96fa684f72e378ddd0ad1107ff44a5c98519 SHA512 5ea0bbf692fa71fa77b0b78307cceee067c95e80c2e69e173990c1154df8014912f24f8d023eda79da56b7c1bdf0870e5e92b968a68c4961af3fc1382d4f468c
+DIST eog-plugins-3.26.4.tar.xz 477772 BLAKE2B 104ddf58d33e5513349839312fef820af20d7a3e64a3a8cbd7d964d8250564d6cd62c58cf95fb5359ab95eac8fe2b83ed051e6f3dc8144a8884ec72c74a12622 SHA512 95f2cf2c6ed84b4801517a708f18e1cd673f814d849029a41491f3719512d6a3a2cb5cb11898a7f972f8b674c682245c99964ba2da19b285ed175b720d5396e8
diff --git a/media-gfx/eog-plugins/eog-plugins-3.26.4.ebuild b/media-gfx/eog-plugins/eog-plugins-3.26.4.ebuild
new file mode 100644
index 000000000000..8cdfa42dd1c0
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.26.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_5,3_6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}