summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-03 23:35:22 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-03 23:38:34 +0100
commit7a31eceb1d95b0a7e5c80736e56511aa59cc78c2 (patch)
tree68fdee30366ffe8ff7a340105089e7e8fe1021c2
parentnet-libs/nghttp2: drop 1.47.0, 1.48.0, 1.49.0, 1.50.0 (diff)
downloadgentoo-7a31eceb.tar.gz
gentoo-7a31eceb.tar.bz2
gentoo-7a31eceb.zip
net-libs/nghttp2: fix automagic deps and cross-compile failure
Closes: https://bugs.gentoo.org/885485 Closes: https://bugs.gentoo.org/895496 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.51.0-r1.ebuild79
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild9
3 files changed, 86 insertions, 3 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 56d9d6df1022..bcdf39180bbc 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,2 +1,3 @@
DIST nghttp2-1.48.0-pthread.patch 24917 BLAKE2B 22013d89685be603094aa82f69da8741d4c0d76aea8a01de1322c19cef053964fdf0bec937650382f85607ac74466d4d052e6d40217101bc1e40326ad0ddc003 SHA512 bdebc50f13584826d6693aae201db9be63fcadcb8a68af188e94f008e005a2fd6aa6b91b31de2f07f84b93d981a003c8752c5fb4d47502f768bd94e21635627f
+DIST nghttp2-1.51.0-pthread.patch 24623 BLAKE2B 55c63b4851788e4e18df1f7881fc370bf901c2df2249243e18e2a49f2142454438b41ecd941ed888ca065cdb037bd52624231a97a06eae4f97ebbc24cd890a46 SHA512 eaa85373f977bd4383d11d6077d69c80cf254ec49f4686a0140765a84806f6691f435fd5d558d4642cbf4a364f274c16b50d3f63c4e9507b6dc3b1317498e15a
DIST nghttp2-1.51.0.tar.xz 4115988 BLAKE2B ca3c5fb439b60f67ce5447c957397c16c7659432d3a3b25076b88142318675eb2af9f039a86ce88df8af3bd0167d98f14cdeb8dad2d01eda1378015acefa354e SHA512 0212680e57a15f9afca3b5226429edebd2fe8a52117480007d4472cd0c1bd3aa4d9f21269c637a11efd0f2146a3ee16c3c07ab35d9fb3d4566235d3a14268eeb
diff --git a/net-libs/nghttp2/nghttp2-1.51.0-r1.ebuild b/net-libs/nghttp2/nghttp2-1.51.0-r1.ebuild
new file mode 100644
index 000000000000..7ea2f6f9886a
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.51.0-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~voyageur/distfiles/${PN}-1.51.0-pthread.patch"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="cxx debug hpack-tools jemalloc static-libs systemd test utils xml"
+
+RESTRICT="!test? ( test )"
+
+SSL_DEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist(-),${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP}]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5:= )
+ jemalloc? ( dev-libs/jemalloc:=[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ systemd? ( sys-apps/systemd )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${DISTDIR}"/${PN}-1.51.0-pthread.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-python-bindings
+ --disable-werror
+ --enable-threads
+ --without-cython
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(multilib_native_use_with hpack-tools jansson)
+ $(multilib_native_use_with jemalloc)
+ $(use_enable static-libs static)
+ $(multilib_native_use_with systemd)
+ $(use_with test cunit)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if ! use static-libs ; then
+ find "${ED}"/usr -type f -name '*.la' -delete || die
+ fi
+}
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index 67529daca48f..b24cbd6c83f0 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# TODO: Add python support.
@@ -14,7 +14,7 @@ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
LICENSE="MIT"
SLOT="0/1.14" # <C++>.<C> SONAMEs
KEYWORDS=""
-IUSE="cxx debug hpack-tools jemalloc static-libs test utils xml"
+IUSE="cxx debug hpack-tools jemalloc static-libs systemd test utils xml"
RESTRICT="!test? ( test )"
@@ -34,6 +34,7 @@ RDEPEND="
>=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
net-dns/c-ares:=[${MULTILIB_USEDEP}]
)
+ systemd? ( sys-apps/systemd )
xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
@@ -55,10 +56,12 @@ multilib_src_configure() {
$(use_enable cxx asio-lib)
$(use_enable debug)
$(multilib_native_use_enable hpack-tools)
+ $(multilib_native_use_with hpack-tools jansson)
+ $(multilib_native_use_with jemalloc)
$(use_enable static-libs static)
+ $(multilib_native_use_with systemd)
$(use_with test cunit)
$(multilib_native_use_enable utils app)
- $(multilib_native_use_with jemalloc)
$(multilib_native_use_with xml libxml2)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"