summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-12-25 18:06:55 +0100
committerPacho Ramos <pacho@gentoo.org>2019-12-25 18:08:03 +0100
commit7a550f9142402d46d9a46b0a298d0891b267aff3 (patch)
tree1bd876ec7f771ce0dcf87fad8554aab04d0dbf84
parentsci-mathematics/wxmaxima: cleaning old versions (diff)
downloadgentoo-7a550f9142402d46d9a46b0a298d0891b267aff3.tar.gz
gentoo-7a550f9142402d46d9a46b0a298d0891b267aff3.tar.bz2
gentoo-7a550f9142402d46d9a46b0a298d0891b267aff3.zip
games-arcade/solarwolf: Debian fixes, python3 support
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--games-arcade/solarwolf/Manifest1
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5-r2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-arcade/solarwolf/Manifest b/games-arcade/solarwolf/Manifest
index 20ce6d8d7d28..dd673590cfdb 100644
--- a/games-arcade/solarwolf/Manifest
+++ b/games-arcade/solarwolf/Manifest
@@ -1 +1,2 @@
DIST solarwolf-1.5.tar.gz 2045888 BLAKE2B 66498b1d9b202b45ff87ea9d4b1ab14dcb6e343e8b0761576cfbf1c84ee9575cbf665e4b94552eb764f5e4fbaa02739f62c9eb20217085a6d18483d3ca7eb587 SHA512 44d84976f7797e3b859f1e5e50f9f964e5c6d6d4437ad25cf04720035e8697cc0c86490fdbbf8d923320a5c15c6e3afd1fbcfb9f17e7e31ce6f7264004e991f2
+DIST solarwolf_1.5+dfsg1-1.debian.tar.xz 8392 BLAKE2B 099543a22e93775756a90867dfeb7926ab9131b8367fa356a6d74efb682d17c5426f5f5372079052967a752a0c75e1d2db36b2ce0b43d00010c65468da968817 SHA512 b4d8ad1a0e83e4cf97185b075a53b7f66fbc20f865e490f714295f678fc675a111d2318e7c0b543028b5d948677140070acb9c04b07fdab1165e37606f34d87a
diff --git a/games-arcade/solarwolf/solarwolf-1.5-r2.ebuild b/games-arcade/solarwolf/solarwolf-1.5-r2.ebuild
new file mode 100644
index 000000000000..cf1968f26914
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.5-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit desktop eutils python-r1
+
+DESCRIPTION="Action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="
+ http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}+dfsg1-1.debian.tar.xz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pygame-1.5.6
+ media-libs/sdl-mixer[mod,vorbis]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+
+ eapply -p1 "${WORKDIR}"/debian/patches/*.patch
+
+ find . -name .xvpics -print0 | xargs -0 rm -fr
+ gunzip dist/${PN}.6.gz || die #619948
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r code data *py
+ make_wrapper ${PN} "python3 ./solarwolf.py" /usr/share/${PN}
+ newicon data/ship-big.png ${PN}.png
+ make_desktop_entry ${PN} SolarWolf
+ einstalldocs
+ doman dist/${PN}.6
+}