summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 18:41:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 18:48:57 +0200
commit7a5bd5f562823f52e6176189ede3703d52c52638 (patch)
tree7bd8eb100fe92ae0b91f110bd2a684e2ffb1a249
parentdev-python/toml: Enable py3.11 (diff)
downloadgentoo-7a5bd5f5.tar.gz
gentoo-7a5bd5f5.tar.bz2
gentoo-7a5bd5f5.zip
dev-python/characteristic: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/characteristic/characteristic-14.3.0-r4.ebuild b/dev-python/characteristic/characteristic-14.3.0-r4.ebuild
new file mode 100644
index 000000000000..ed2a14b90f2a
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.3.0-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="
+ https://characteristic.readthedocs.io/
+ https://github.com/hynek/characteristic/
+ https://pypi.org/project/characteristic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}