summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-29 11:10:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-29 11:10:03 +0100
commit7a73ef5e9d19ada0e8f15b6623350a1ec7fd9573 (patch)
tree6aa3b44d53412247ec13a03e67d3d204acab448f
parentdev-python/pyspelling: Remove old (diff)
downloadgentoo-7a73ef5e9d19ada0e8f15b6623350a1ec7fd9573.tar.gz
gentoo-7a73ef5e9d19ada0e8f15b6623350a1ec7fd9573.tar.bz2
gentoo-7a73ef5e9d19ada0e8f15b6623350a1ec7fd9573.zip
dev-python/dask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2023.12.1.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 5bc66efa63be..73700a2519e4 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,2 @@
-DIST dask-2023.12.1.gh.tar.gz 8967874 BLAKE2B f397512fb50a53719fff8e234db0e366b17c9abaca4b98c0b1d4a98287dec7f869612e688cfa2e717fc35c4ed1f7a8d8fe74c7dec939e8f669e6790490005370 SHA512 4a90239e83e7cbd4797ee91dc9609d7322a7003b976ed3309de95b47d20e2e9f449cea803618539c5f80ec552dd2ac71e55c87c024beeabf74062beeb3260292
DIST dask-2024.1.0.gh.tar.gz 8975960 BLAKE2B bcc72c1428d0626eb686551c69b0dcbc7b9615524bbcdbc1bb6d5113929f32d53cc7d0952622d352ef7413057b9f90689471b3540b3748beb6cddd0dbbdef2f6 SHA512 a2a436cba1f84d7223ed049c395807f900bc012d7fb8c8ae18c27b15787885e6a6a02cd17da2cc7f765b26469190217e2c8306495fbfc82e3018e1bcee54d24b
DIST dask-2024.1.1.gh.tar.gz 9328425 BLAKE2B 6b6208c59e0446816a962a9a3dc6a1754eba589810aacdab0c1ce38edd6d593763d1868578a344babfa74afd390ac1997d2461586b12180679fdc67ae26e0a74 SHA512 a5e424333c5d19f67d73c2b036544ef03122a99c2eb6a52019929f1e7b87297c776cbea713062372cf1685ef3b79d47734d6d0acd2c054ffadcbb3d96fb6deeb
diff --git a/dev-python/dask/dask-2023.12.1.ebuild b/dev-python/dask/dask-2023.12.1.ebuild
deleted file mode 100644
index 1fa97a3f32d4..000000000000
--- a/dev-python/dask/dask-2023.12.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
-HOMEPAGE="
- https://www.dask.org/
- https://github.com/dask/dask/
- https://pypi.org/project/dask/
-"
-SRC_URI="
- https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/click-8.1[${PYTHON_USEDEP}]
- >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
- >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/toolz[${PYTHON_USEDEP}]
- >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # fails with sqlalchemy-2.0, even though we don't use it x_x
- sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
- sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # more tests relying on -Werror
- "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
- dask/array/tests/test_random.py::test_RandomState_only_funcs
- # TODO
- dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
- dask/tests/test_config.py::test__get_paths
- dask/array/tests/test_linalg.py::test_solve_assume_a
- "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
- "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
- dask/array/tests/test_image.py::test_preprocess
- dask/tests/test_system.py::test_cpu_count_cgroups_v2
- # require sqlalchemy<2.0
- dask/dataframe/io/tests/test_sql.py
- # crashes
- dask/tests/test_base.py::test_tokenize_object_with_recursion_error
- )
-
- if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- # fails if pyarrow is installed without USE=parquet
- # (optional dep, skipped if it's not installed at all)
- dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_rerunfailures -m "not network" \
- -p xdist -n "$(makeopts_jobs)"
-}