summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-02 10:03:11 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-02 10:06:09 +0300
commit7a7a8cbba3af7e1d8782a611345a248b5ba65a6e (patch)
treed917c90bf0ba1218b7594fa93b3830007b9eb03b
parentgames-puzzle/gnome-taquin: bump to 3.28.0 for translation updates (diff)
downloadgentoo-7a7a8cbba3af7e1d8782a611345a248b5ba65a6e.tar.gz
gentoo-7a7a8cbba3af7e1d8782a611345a248b5ba65a6e.tar.bz2
gentoo-7a7a8cbba3af7e1d8782a611345a248b5ba65a6e.zip
app-text/gspell: bump to 1.6.1
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.6.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 8d5386cfa4c5..f43f7d84afd6 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1 +1,2 @@
DIST gspell-1.4.2.tar.xz 407356 BLAKE2B f2ee6ae43be55e8ad7253e10893868a8d7857bbe41e14d71103b27a0faf40b0ed247e9fa38ed7bc75039fe0f1f600fe739f538d50f69fb063d0932df6c0b1c27 SHA512 00f53d3ca47a4ba1af1e8b4983a41dc6df8a9788898b45ffdd161a3fc8de28024cc985f49fbb872912c0a94addbca3b28ce2edda70eeb206a794e2bcf65e4a5e
+DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
diff --git a/app-text/gspell/gspell-1.6.1.ebuild b/app-text/gspell/gspell-1.6.1.ebuild
new file mode 100644
index 000000000000..483713d17e13
--- /dev/null
+++ b/app-text/gspell/gspell-1.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-fbsd"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}