summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-20 06:28:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-20 07:23:59 +0100
commit7aaeaa06f1986a0ae58ae11b10183974b7fe67ef (patch)
tree89a5ea83a892f2dc3f9d9d6cec9f8fdfb34749fa
parentdev-python/scipy: Bump to 1.10.1 (diff)
downloadgentoo-7aaeaa06f1986a0ae58ae11b10183974b7fe67ef.tar.gz
gentoo-7aaeaa06f1986a0ae58ae11b10183974b7fe67ef.tar.bz2
gentoo-7aaeaa06f1986a0ae58ae11b10183974b7fe67ef.zip
dev-python/rq: Bump to 1.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.13.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 09b2601445f8..75ea05c62281 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1,3 @@
DIST rq-1.11.1.gh.tar.gz 604043 BLAKE2B 57169a50fe9c2724c4e61a23e4d73d23af6aae241276dac414d2a065675e64bdd1fd35500903e7c276345a0a713a87dc7642894cdb887f019e82606fa668eba3 SHA512 ce5a2bf1fb2757d248704461ef9b631443610a11fa1c832e8aad62e68812d478c51e7bbd0d1ed4a9af678d3a9c85067e1cf16547653851ffb8c19e36b97ba945
DIST rq-1.12.0.gh.tar.gz 611434 BLAKE2B 8e13d7c02a56fe71cb3e492654c124f8b0cdbda298687bfc57b3037ff85a6416d7356125e48ae723225739dd0ef0eab49fbb2ed5b2e424c93d1a177c85f00800 SHA512 32d10a96213bd23f21f3dada53771047f9d66a73590a0f1cc0086981f1f9276e0bc9d51b8fd3ba12a140ea71b004c995a82aa6746e1a793374f8fea762602c18
+DIST rq-1.13.0.gh.tar.gz 616679 BLAKE2B 026914ab01f769797e1f7fabc944b5ccdeb1ce1957c7acc72d067e0bdd113ebb30f0060ea5adbceaac5e69b40e176c09a0b1f216cffb02132772e72151b79986 SHA512 6c3b4bb868cae6ffd07718b3f517350eba2effc1b3ae70ef601984cc525ecfb3f82f8569a2b0f333c5f248d3befbe3d4953f5058f8e9cb2f08ce6dadae963902
diff --git a/dev-python/rq/rq-1.13.0.ebuild b/dev-python/rq/rq-1.13.0.ebuild
new file mode 100644
index 000000000000..7483126181b1
--- /dev/null
+++ b/dev-python/rq/rq-1.13.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+SRC_URI="
+ https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-3.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}