summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-20 00:20:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-20 00:54:02 +0200
commit7ab11defd01d94cd24cec84fd414b3eae7cd6061 (patch)
tree463b1f50076668955d9c63b7f945d31a49c60ddf
parentgames-simulation/flightgear: Version bump 2017.3.1 (diff)
downloadgentoo-7ab11defd01d94cd24cec84fd414b3eae7cd6061.tar.gz
gentoo-7ab11defd01d94cd24cec84fd414b3eae7cd6061.tar.bz2
gentoo-7ab11defd01d94cd24cec84fd414b3eae7cd6061.zip
kde-apps/kdepim-runtime: Add USE=speech
Upstream commit 132d5d83940f0304d036601a41a6f428cbd6c999 Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-17.08.2-r1.ebuild81
-rw-r--r--kde-apps/kdepim-runtime/metadata.xml15
2 files changed, 89 insertions, 7 deletions
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-17.08.2-r1.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-17.08.2-r1.ebuild
new file mode 100644
index 000000000000..4073c1b8ac0d
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-17.08.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+# TODO kolab
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkgapi)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libxslt
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-apps/kdepim-runtime/metadata.xml b/kde-apps/kdepim-runtime/metadata.xml
index 79bfb58e5487..36d85d6c5631 100644
--- a/kde-apps/kdepim-runtime/metadata.xml
+++ b/kde-apps/kdepim-runtime/metadata.xml
@@ -1,11 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
-</maintainer>
-<use>
- <flag name="google">Google service integration via <pkg>kde-apps/libkgapi</pkg></flag>
-</use>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="google">Google service integration via <pkg>kde-apps/libkgapi</pkg></flag>
+ <flag name="speech">Enable text-to-speech support</flag>
+ </use>
</pkgmetadata>