summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 22:23:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 23:19:57 +0100
commit7ac2555744e2c12ebe04137122da65c3cc55de58 (patch)
tree10e0a4e5a03fd2eb98f738f311d5776cd1d8feb5
parentapp-backup/sarab: drop 1.0.0 (diff)
downloadgentoo-7ac25557.tar.gz
gentoo-7ac25557.tar.bz2
gentoo-7ac25557.zip
dev-libs/rapidjson: drop 1.1.0-r3
Closes: https://bugs.gentoo.org/917390 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild b/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
deleted file mode 100644
index 73b3f54b7a78..000000000000
--- a/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A fast JSON parser/generator for C++ with both SAX/DOM style API"
-HOMEPAGE="https://rapidjson.org/"
-
-LICENSE="MIT"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/miloyip/rapidjson.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/miloyip/rapidjson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86"
- S="${WORKDIR}/rapidjson-${PV}"
-fi
-
-DEPEND="
- doc? ( app-doc/doxygen )
- test? ( dev-cpp/gtest )"
-RDEPEND=""
-
-PATCHES=(
- "${FILESDIR}/${P}-gcc-7.patch"
- "${FILESDIR}/${P}-system_gtest.patch"
- "${FILESDIR}/${P}-valgrind_optional.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i -e 's| -march=native||g' CMakeLists.txt || die
- sed -i -e 's| -Werror||g' CMakeLists.txt example/CMakeLists.txt test/unittest/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDOC_INSTALL_DIR="${EPREFIX}/usr/share/doc/${PF}"
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DRAPIDJSON_BUILD_CXX11=OFF # latest gtest requires C++14 or later
- -DRAPIDJSON_BUILD_DOC=$(usex doc)
- -DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
- -DRAPIDJSON_BUILD_TESTS=$(usex test)
- -DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
- )
- use test && mycmakeargs+=(
- -DVALGRIND_EXECUTABLE=
- )
- cmake_src_configure
-}