summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-11-06 22:58:59 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-07 12:33:43 +0100
commit7acb1f9f858574a994c30c73f0c3edfbbd3f0700 (patch)
tree418fcb91db036d8a4f5b82bae9f8ec319dae4c35
parentsci-misc/jupyterlab-desktop-bin: drop deprecated dependency (diff)
downloadgentoo-7acb1f9f.tar.gz
gentoo-7acb1f9f.tar.bz2
gentoo-7acb1f9f.zip
sys-process/btop: add 1.2.13
Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://github.com/gentoo/gentoo/pull/28161 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-process/btop/Manifest1
-rw-r--r--sys-process/btop/btop-1.2.13.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-process/btop/Manifest b/sys-process/btop/Manifest
index c01df74cd1ce..b772e97b9196 100644
--- a/sys-process/btop/Manifest
+++ b/sys-process/btop/Manifest
@@ -1,2 +1,3 @@
DIST btop-1.2.12.tar.gz 980406 BLAKE2B ddaa023b85a00edfb27b55e574950934cce578ad7bbf0ea03b2780a511078638c14cd2316ebce8701be76c13ed3af8f0ded703071b363fddc14bcbea040279dd SHA512 36bf329a7b9922ff5cae990f5528625280b6b3fcb83d0af2e502876a2a8f4864c3a6ecbc6cb5aaa885f637859eef66470ff0cc86036f76b499b23a7c4086ea60
+DIST btop-1.2.13.tar.gz 982660 BLAKE2B 053c1ef87203b894c2cbe6007c3b5962dca232733d28f97d82a2f70e771d4cc92fe4c49d3582c80cb79974d65329d3e95e758b9e8a7fa51a2ff0cdbf6cbd9a75 SHA512 324e572d43e57e5e65e646aa743f7730e6d535fdc52e848aeb55d60c8d73945850c5b89fe0b541e98495ddf2bae71427a6ec8fe8a495b41cef885c535d01019b
DIST btop-1.2.9.tar.gz 978265 BLAKE2B ff80079a393342a2cf3aefad6ead8be8b786fbc2b9445e8e2a8b37386f65f4060c801a6f59d216cd611783f4135a60d64b95ff2b5e1a3d62bb2d40030bde8974 SHA512 424573c8f82d0daf748cba7c82e72232773f145af9792ac78a5f5f18d98a8695f11452de106c72cf685ecb8cc89729471a494f9ea6b4300bdb2fa6acdbf4ac60
diff --git a/sys-process/btop/btop-1.2.13.ebuild b/sys-process/btop/btop-1.2.13.ebuild
new file mode 100644
index 000000000000..77749296de4f
--- /dev/null
+++ b/sys-process/btop/btop-1.2.13.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="A monitor of resources"
+HOMEPAGE="https://github.com/aristocratos/btop"
+SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ # btop installs README.md to /usr/share/btop by default
+ sed -i '/^.*cp -p README.md.*$/d' Makefile || die
+}
+
+src_compile() {
+ # Disable btop optimization flags, since we have our flags in CXXFLAGS
+ emake VERBOSE=true OPTFLAGS="" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ DESTDIR="${D}" \
+ install
+
+ dodoc README.md CHANGELOG.md
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}