summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-09-10 10:44:59 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-09-10 11:03:51 -0700
commit7ad4125ae70e9d2162c4295f4acac761d8434257 (patch)
treeb786eaf3d61182317e4dba553a33ae4496fb652d
parentdev-python/pymad: enable py3.12 (diff)
downloadgentoo-7ad4125ae70e9d2162c4295f4acac761d8434257.tar.gz
gentoo-7ad4125ae70e9d2162c4295f4acac761d8434257.tar.bz2
gentoo-7ad4125ae70e9d2162c4295f4acac761d8434257.zip
dev-util/rizin: add 0.6.1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--dev-util/rizin/Manifest2
-rw-r--r--dev-util/rizin/rizin-0.6.1.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index f068b6f62e8c..47d7dc4fea32 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -1,4 +1,6 @@
DIST rizin-src-v0.5.1.tar.xz 11770688 BLAKE2B 31369497d5aa425aa6030ce404baa5d4a10ef2453a93f9b2c9f7d47135b5ffbc61618ef7e743acef3939bca2838a94637b7a1794ff44998608aee3f988301483 SHA512 c856112651bec91bb6e9f5580f60e3168f02a9f194bf567186a66398c162f59953ca8c3bf43441315356ca6ef077b7c56e4150e2dd8a79d4d08c5f789c549596
DIST rizin-src-v0.5.2.tar.xz 11779644 BLAKE2B d74c02c1f58d099a0047a7a528b7e182980901bc1bf2722aef259e03ddf9af908c3ebcde4f1268fcbd07125a21f064259601a54c6b8413e19f6b85c95113cf3d SHA512 2fbd3873c7725d4fa1dee53d685c4a5d372013f300cd19dd92752b82987f049a4eba77b4d4ae33b576678714752147355ac486951949a35275cc3fdc5447a351
+DIST rizin-src-v0.6.1.tar.xz 15397540 BLAKE2B d641279505be2f58b1874d431922066e09affef20e18025c0d3781dbe1fad8f12db53335464ad645344daa25a0ed61fa842fa96bcca6c4832b359b424b5f09a3 SHA512 56ed3c9f7e4e689dfc27461b5a2de9cc6d14fec2e4cc17af6a011975fbecd4f2ec44e8dd26f0ce8f99a448b75514f6083177acfd073182bbdf921bc264fa9561
DIST rizin-testbins-0264ae4ee5bd606ec6c6a539255eeb57ce2c82c2.tar.gz 179281553 BLAKE2B b86278589da2f8e5859b0f4b16e2667a6e7477c9a889158da5a2c1a1b6e29af4798d56a22dd4c3e23aec1908e7b444ca999502e73f8d8ccf4e0bf2a969380564 SHA512 ae11b6da5cb995f8f1cc996a7b772234b3e7e7c2b0695d0b223657ba839c82dbbcb390600aeb0d16c7c61a5037ba9d0739df79efd730c1b96392cfc1e6f6613d
DIST rizin-testbins-d66f95359fe830514267f446975374752201c3f1.tar.gz 179428523 BLAKE2B 9d18c2f49460e26809bc526eab9d7bfed15d3fb3f94b22d327f9981547130f82107259f2942e098834cd8ad755e8eadb4b8459a10070105ec116b16fbac19fe3 SHA512 cdeefc6e4103e99c4581a45475c2326505f8003c80a158a78be32b27dfa65fe42a80bbf25ffc47c1f8abdd50faba0fb073a7236395ab67eafb0202695877c4ba
+DIST rizin-testbins-e959eb18182724809b78ad94cb7a9cdfbc5e3a6f.tar.gz 181638434 BLAKE2B 87c853d5e8b892cc5487bc4b2b7a09bd68292d0dc15eeb94f00aa12c3cdea2b4f3e147e62fc2de1beeeaec941b85981843310bd981f8679993db9473e638db31 SHA512 55bd5c2e91856e16318c3e342302f1e6dc9bb8059dbd5aee6f1643f08fe710e32ab91f084fdfce1746a9fbc1dcdfb55b01135b4de74bca6c5b99c7a06bf46ae6
diff --git a/dev-util/rizin/rizin-0.6.1.ebuild b/dev-util/rizin/rizin-0.6.1.ebuild
new file mode 100644
index 000000000000..5df5dce6965d
--- /dev/null
+++ b/dev-util/rizin/rizin-0.6.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+# This is the commit that the CI for the release commit used
+BINS_COMMIT="e959eb18182724809b78ad94cb7a9cdfbc5e3a6f"
+
+inherit meson python-any-r1
+
+DESCRIPTION="reverse engineering framework for binary analysis"
+HOMEPAGE="https://rizin.re/"
+
+SRC_URI="mirror+https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
+ test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+LICENSE="Apache-2.0 BSD LGPL-3 MIT"
+SLOT="0/${PV}"
+IUSE="test"
+
+# Need to audit licenses of the binaries used for testing
+RESTRICT="test? ( fetch ) !test? ( test )"
+
+# TODO: unbundle dev-libs/blake3
+RDEPEND="
+ app-arch/lz4:0=
+ app-arch/xz-utils
+ >=dev-libs/capstone-5:0=
+ dev-libs/libmspack
+ dev-libs/libzip:0=
+ dev-libs/openssl:0=
+ >=dev-libs/tree-sitter-0.19.0
+ dev-libs/xxhash
+ sys-apps/file
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.0-never-rebuild-parser.patch"
+ "${FILESDIR}/${PN}-0.5.2-find-tree-sitter-parser.patch"
+)
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+
+ local py_to_mangle=(
+ librz/core/cmd_descs/cmd_descs_generate.py
+ sys/clang-format.py
+ test/fuzz/scripts/fuzz_rz_asm.py
+ test/scripts/gdbserver.py
+ )
+
+ python_fix_shebang "${py_to_mangle[@]}"
+
+ # https://github.com/rizinorg/rizin/issues/3459
+ sed -ie '/dyld_chained_ptr_arm64e_auth/d' test/unit/test_bin_mach0.c || die
+
+ if use test; then
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcli=enabled
+ -Duse_sys_capstone=enabled
+ -Duse_sys_libmspack=enabled
+ -Duse_sys_libzip=enabled
+ -Duse_sys_lz4=enabled
+ -Duse_sys_lzma=enabled
+ -Duse_sys_magic=enabled
+ -Duse_sys_openssl=enabled
+ -Duse_sys_tree_sitter=enabled
+ -Duse_sys_xxhash=enabled
+ -Duse_sys_zlib=enabled
+
+ $(meson_use test enable_tests)
+ $(meson_use test enable_rz_test)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We can select running either unit or integration tests, or all of
+ # them by not passing --suite. According to upstream, integration
+ # tests are more fragile and unit tests are sufficient for testing
+ # packaging, so only run those.
+ meson_src_test --suite unit
+}