summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-01-08 14:00:49 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-01-08 14:01:05 +0100
commit7ad827e3aba93f2f55956da4c6126bcdbf639a4a (patch)
tree2aa0722a50df920e3b32945d096d033adb4497f6
parentnet-ftp/filezilla: 3.52.0.5 bump, remove previous version (diff)
downloadgentoo-7ad827e3aba93f2f55956da4c6126bcdbf639a4a.tar.gz
gentoo-7ad827e3aba93f2f55956da4c6126bcdbf639a4a.tar.bz2
gentoo-7ad827e3aba93f2f55956da4c6126bcdbf639a4a.zip
media-libs/ganv: 1.8.0 bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-libs/ganv/Manifest1
-rw-r--r--media-libs/ganv/ganv-1.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/ganv/Manifest b/media-libs/ganv/Manifest
index 191d098b544c..dd45510637ff 100644
--- a/media-libs/ganv/Manifest
+++ b/media-libs/ganv/Manifest
@@ -1 +1,2 @@
DIST ganv-1.6.0.tar.bz2 377068 BLAKE2B f78c4783f0188fd163b087c789d50eb67a54a77d26d261d3557fba46a7bee09fc3326204273ad496d6b2ae262368015c3f186c290f2b85e6d5297eeed7596677 SHA512 05900aa63e65646e75f805dfe6ae5901efb19ae31a3f0a6730a713bfaffc47bb93f683879ce2a75093ea09e84a9d3137966b68b4ad307707753dead1df439a09
+DIST ganv-1.8.0.tar.bz2 382822 BLAKE2B 4936b7f87fa7cf17ed86b8165558684f0f59387c9673144d57d8505e41f367735117e9f5b08508dcecb831b77b6bbc6559323417824a9f8defc43c81cc91d469 SHA512 00969879592af11d211ad790b970a8a3765ec0591515af856230e3fc9371b1611f2a4edc73d1fc59371a4c4a49c7479f279dc6f298d843296e6707cd2d495af4
diff --git a/media-libs/ganv/ganv-1.8.0.ebuild b/media-libs/ganv/ganv-1.8.0.ebuild
new file mode 100644
index 000000000000..eaeb8d96462a
--- /dev/null
+++ b/media-libs/ganv/ganv-1.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE='threads(+)'
+inherit eutils flag-o-matic waf-utils python-any-r1
+
+DESCRIPTION="A GTK+ widget for interactive graph-like environments"
+HOMEPAGE="http://drobilla.net/software/ganv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fdgl +graphviz introspection nls"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ x11-libs/gtk+:2
+ graphviz? ( media-gfx/graphviz[gtk] )
+ introspection? (
+ app-text/yelp-tools
+ dev-libs/gobject-introspection:=[doctool] )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ nls? ( virtual/libintl )
+"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ waf-utils_src_configure \
+ $(use graphviz || echo "--no-graphviz") \
+ $(use fdgl || echo "--no-fdgl") \
+ $(use nls || echo "--no-nls") \
+ $(use introspection && echo "--gir")
+}