summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-29 02:00:06 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-29 02:18:10 -0400
commit7adfa307a9fc677eb552093bb35bb6bbe1f0c3b1 (patch)
tree4b63ef5dc0e61a593122e6cb09fba1132aa3bbc1
parentdev-python/cryptography-vectors: version bump to 2.1.2 (diff)
downloadgentoo-7adfa307.tar.gz
gentoo-7adfa307.tar.bz2
gentoo-7adfa307.zip
sys-process/parallel: version bump to 20171022 and add myself as a maintainer
-rw-r--r--sys-process/parallel/Manifest1
-rw-r--r--sys-process/parallel/metadata.xml31
-rw-r--r--sys-process/parallel/parallel-20171022.ebuild40
3 files changed, 58 insertions, 14 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index 5faf0a881740..a768ffbb97c8 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -1,2 +1,3 @@
DIST parallel-20170422.tar.bz2 1543900 SHA256 7a2438a92692c662dae3d4e80f1190af4cfe527cd3fb1a0d14e07f5c110ed329 SHA512 3785221751ef334db0c999819dd6a6cfae20400b1257467325e1533cbff3ea02a1008b61636bd8ec11b270a95c081c89f4be46d2d7a4fe8585e402f320e7c870 WHIRLPOOL 10cad743046eef4740c26272adc015cdb0ffb5fbc695343c9d3022bc3bef1cb4f63c0b883d65b7f3d97339e6d4c65a11ffe86e01a8fa45eae8457ac0f3398660
DIST parallel-20170822.tar.bz2 1622834 SHA256 8949bfa3057e194119a85a8cba2c8e0bdd46b5f5851eda583d2386b95c039148 SHA512 d0ce008a1d10f6802b141835a931bbbe533d5a4ca41c5636dae1ccecd5ad6b0385d36f11ba33970053dc293d2a44524921a84c2f4f38e9adcb48e435fcdb29dd WHIRLPOOL 564b051677e62d2ec8d1200f1a079b34f72dc737b678aa45a7a6e2c6026e449d22dcd4018482bd978f27119476a3aa00fb29136080f008cccb781c303fffa6bb
+DIST parallel-20171022.tar.bz2 1665411 SHA256 f7e2bb7467cd3e87c5488e324950f2710e5d6cc9c9b3c33931e71d7a2d08f8a2 SHA512 1b265482e0e79035e6febb9363ed2b8b34fe6e9ddc751fbf9764bd38cc85c5123aa3034b4f3937f476969cb70a3b14a724ee990a7270ab0bf3b543596f521390 WHIRLPOOL 8d74473ac0f66729d242ca219b3cfbdc7ef1724a8c1c20de6f13044d741b355540924dc074129bce7b4bb68df250ddafcd6c79f0bb57a4e8a336589ba4a4904c
diff --git a/sys-process/parallel/metadata.xml b/sys-process/parallel/metadata.xml
index ad396001fdbd..d8b0e212d636 100644
--- a/sys-process/parallel/metadata.xml
+++ b/sys-process/parallel/metadata.xml
@@ -1,19 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription lang="en">
-GNU parallel is a shell tool for executing jobs in parallel locally or
-using remote machines. A job is typically a single command or a small
-script that has to be run for each of the lines in the input. The
-typical input is a list of files, a list of hosts, a list of users, a
-list of URLs, or a list of tables.
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ GNU parallel is a shell tool for executing jobs in parallel locally or
+ using remote machines. A job is typically a single command or a small
+ script that has to be run for each of the lines in the input. The
+ typical input is a list of files, a list of hosts, a list of users, a
+ list of URLs, or a list of tables.
-If you use xargs today you will find GNU parallel very easy to use as
-GNU parallel is written to have the same options as xargs. If you
-write loops in shell, you will find GNU parallel may be able to
-replace most of the loops and make them run faster by running several
-jobs in parallel. If you use ppss or pexec you will find GNU parallel
-will often make the command easier to read.
-</longdescription>
+ If you use xargs today you will find GNU parallel very easy to use as
+ GNU parallel is written to have the same options as xargs. If you
+ write loops in shell, you will find GNU parallel may be able to
+ replace most of the loops and make them run faster by running several
+ jobs in parallel. If you use ppss or pexec you will find GNU parallel
+ will often make the command easier to read.
+ </longdescription>
</pkgmetadata>
diff --git a/sys-process/parallel/parallel-20171022.ebuild b/sys-process/parallel/parallel-20171022.ebuild
new file mode 100644
index 000000000000..cfc66354fd89
--- /dev/null
+++ b/sys-process/parallel/parallel-20171022.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/perl:=
+ dev-perl/Devel-Size
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+DEPEND="${RDEPEND}"
+
+DOCS="NEWS README"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # See src/Makefile.am for this one:
+ rm -f "${ED}"usr/bin/sem
+ dosym ${PN} /usr/bin/sem
+}
+
+pkg_postinst() {
+ elog "To distribute jobs to remote machines you'll need these dependencies"
+ elog " net-misc/openssh"
+ elog " net-misc/rsync"
+}