summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:30:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:45:55 -0600
commit7afdd889287cdc0aee6606d74859afba9936b621 (patch)
tree58bb5320abf26c6566c0bbffe333c72ba98d6f2a
parentdev-python/casttube: add for pychromecast (diff)
downloadgentoo-7afdd889287cdc0aee6606d74859afba9936b621.tar.gz
gentoo-7afdd889287cdc0aee6606d74859afba9936b621.tar.bz2
gentoo-7afdd889287cdc0aee6606d74859afba9936b621.zip
dev-python/pychromecast: 4.1.0 add for pulseaudio-dlna
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/pychromecast/Manifest1
-rw-r--r--dev-python/pychromecast/metadata.xml14
-rw-r--r--dev-python/pychromecast/pychromecast-4.1.0.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pychromecast/Manifest b/dev-python/pychromecast/Manifest
new file mode 100644
index 000000000000..7c62c88d53ab
--- /dev/null
+++ b/dev-python/pychromecast/Manifest
@@ -0,0 +1 @@
+DIST PyChromecast-4.1.0.tar.gz 44463 BLAKE2B 3ee92cfe57134665621c347dda9b21a06fa1d000f840d25b49f843edef86e35e22b82c9d4f80b8e0ae6f5fabcc4662d7c619363686a37903e27d84e0f85c8fca SHA512 688014a115f3189fed5535e70622a7323e4a29fd65678aa14a302047c5246dbc6a932a8f4eabb58f9fcecc0f4bdbe627d1496a4b6d28e680ad4fac6dd902c825
diff --git a/dev-python/pychromecast/metadata.xml b/dev-python/pychromecast/metadata.xml
new file mode 100644
index 000000000000..24fcd1714e2b
--- /dev/null
+++ b/dev-python/pychromecast/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Library for Python 2 and 3 to communicate with the Google Chromecast.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pychromecast/pychromecast-4.1.0.ebuild b/dev-python/pychromecast/pychromecast-4.1.0.ebuild
new file mode 100644
index 000000000000..382fbb243999
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-4.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Python module to talk to Google Chromecast."
+HOMEPAGE="https://github.com/balloob/pychromecast"
+SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+S="${WORKDIR}/PyChromecast-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.17.7[${PYTHON_USEDEP}]
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]"
+BDEPEND=""