summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-15 13:33:58 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-30 10:36:04 +0200
commit7b2992fd44c5df1a80931e28cb8c1faa7ed2bb89 (patch)
tree96f017d3e97916bf2b18dd0518af2f4764f7285c
parentdev-java/ant-eclipse-ecj: virtual/jdk-11:*" -> -17:* (diff)
downloadgentoo-7b2992fd44c5df1a80931e28cb8c1faa7ed2bb89.tar.gz
gentoo-7b2992fd44c5df1a80931e28cb8c1faa7ed2bb89.tar.bz2
gentoo-7b2992fd44c5df1a80931e28cb8c1faa7ed2bb89.zip
dev-java/eclipse-ecj: virtual/jdk-11:*" -> -17:*
Bug: https://bugs.gentoo.org/831559 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25501 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-4.22-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-4.22-r1.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-4.22-r1.ebuild
new file mode 100644
index 000000000000..82bd5d06ebf2
--- /dev/null
+++ b/dev-java/eclipse-ecj/eclipse-ecj-4.22-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="ecj"
+DMF="R-${PV}-202111241800"
+
+DESCRIPTION="Eclipse Compiler for Java"
+HOMEPAGE="https://www.eclipse.org/"
+SRC_URI="https://download.eclipse.org/eclipse/downloads/drops4/${DMF}/${MY_PN}src-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.22"
+IUSE="+ant"
+
+COMMON_DEP="
+ app-eselect/eselect-java
+ dev-java/ant-core:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-11:*"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-17:*
+ app-arch/unzip"
+PDEPEND="
+ ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+
+JAVA_JAR_FILENAME="${MY_PN}.jar"
+JAVA_GENTOO_CLASSPATH="ant-core"
+
+S="${WORKDIR}"
+
+# See https://bugs.eclipse.org/bugs/show_bug.cgi?id=479134 for details
+src_prepare() {
+ default
+
+ # These have their own package.
+ rm org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -r org/eclipse/jdt/internal/antadapter || die
+
+ # JavaCore is not distributed in the jar
+ sed -i -e '/import org.eclipse.jdt.core.JavaCore;/d' \
+ -e 's|JavaCore.getOptions()||g' \
+ org/eclipse/jdt/internal/compiler/batch/ClasspathDirectory.java
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find org META-INF -type f ! -name "*.java" | xargs jar uvf "${JAVA_JAR_FILENAME}" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${MY_PN}-${SLOT} --main \
+ org.eclipse.jdt.internal.compiler.batch.Main
+}
+
+pkg_postinst() {
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ecj-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}