summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 16:23:56 +0100
committerSam James <sam@gentoo.org>2023-10-04 16:23:56 +0100
commit7b2c0bc0c0770e632db74e52ff4a22d0a39febb6 (patch)
treefe9ebf46e96188f423e056c4023c50411a3190cc
parentnet-libs/libotr: don't redefine _FORTIFY_SOURCE (diff)
downloadgentoo-7b2c0bc0c0770e632db74e52ff4a22d0a39febb6.tar.gz
gentoo-7b2c0bc0c0770e632db74e52ff4a22d0a39febb6.tar.bz2
gentoo-7b2c0bc0c0770e632db74e52ff4a22d0a39febb6.zip
net-analyzer/arp-scan: don't redefine _FORTIFY_SOURCE
Closes: https://bugs.gentoo.org/895522 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/arp-scan/Manifest1
-rw-r--r--net-analyzer/arp-scan/arp-scan-1.10.0.ebuild34
-rw-r--r--net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch25
3 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/arp-scan/Manifest b/net-analyzer/arp-scan/Manifest
index 4af9b8b9d1c6..c8b282d0ff65 100644
--- a/net-analyzer/arp-scan/Manifest
+++ b/net-analyzer/arp-scan/Manifest
@@ -1 +1,2 @@
+DIST arp-scan-1.10.0.tar.gz 653900 BLAKE2B 618a8201a2c7f425dce5b4260857542956caa4beed61fde9d85cf763076c12ef24eb5a059a5d332b739f1e5b2b3d18db922e6299ff46f7e02ddfb54562b3fc3e SHA512 716c7727597bdecf9fd3f064fe1715148c246c223c2adeb01a26417865e4d82b9ca47e7fe4a555e510e0ae65f23f8310f0dbdffdb7c3fd969e3b81d0c6e4ae2a
DIST arp-scan-1.9.7.tar.gz 459544 BLAKE2B bd70b2dd9e005096ce80fca07b8f2d8482b1073d25a2a9f82e8f5c1206148dbeab095046292cb46b5823aa18b56c208a5e86d0b7252d8566ddee5cd714b78cc6 SHA512 2aa808521a64cd3e2a6a270c6725f2cffa4cfce5c251e5483053c8ea9f56fb1368dd9aae2afcf8fffe1030fe2fc37723f0701c9eafa7cd1d52df459c07a80870
diff --git a/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild b/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
new file mode 100644
index 000000000000..7ab46fd66b97
--- /dev/null
+++ b/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="ARP scanning and fingerprinting tool"
+HOMEPAGE="https://github.com/royhills/arp-scan"
+SRC_URI="https://github.com/royhills/arp-scan/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/libcap
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+# Needed for _F_S patch
+BDEPEND="sys-devel/autoconf-archive"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.0-dont-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch b/net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch
new file mode 100644
index 000000000000..f933e965893b
--- /dev/null
+++ b/net-analyzer/arp-scan/files/arp-scan-1.10.0-dont-clobber-fortify-source.patch
@@ -0,0 +1,25 @@
+Don't clobber toolchain defaults.
+
+(TODO: Fix upstream's GCC_FORTIFY_SOURCE macro or just replace it with the
+autoconf-archive one (AX_ADD_FORTIFY_SOURCE)).
+
+https://bugs.gentoo.org/895522
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,7 +37,6 @@ if test -n "$GCC"; then
+ CFLAGS="$CFLAGS -Wall -Wshadow -Wwrite-strings"
+ GCC_WEXTRA
+ GCC_STACK_PROTECT_CC
+- GCC_FORTIFY_SOURCE
+ GCC_FORMAT_SECURITY
+ dnl Uncomment the line below to compile with additional warnings enabled.
+ dnl CFLAGS="$CFLAGS -pedantic -Wpointer-arith -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs"
+@@ -49,6 +48,8 @@ else
+ fi
+ AC_PROG_INSTALL
+
++AX_ADD_FORTIFY_SOURCE
++
+ dnl Checks for libraries.
+ dnl Solaris 10 needs -lnsl for gethostbyname() and -lsocket for socket().
+ dnl Linux, {Free,Open,Net,Dragonfly}BSD and MacOS X do not.