summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-02 05:59:41 +0000
committerSam James <sam@gentoo.org>2023-01-02 05:59:47 +0000
commit7b3b13e2b23c0df42ee8b478c2506e2ca6d99184 (patch)
tree0c0a30de6c5ada7e3736b8a33d17177b61725407
parentgames-emulation/pcsx2: switch icon in live (diff)
downloadgentoo-7b3b13e2.tar.gz
gentoo-7b3b13e2.tar.bz2
gentoo-7b3b13e2.zip
app-arch/cpio: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/cpio/files/cpio-2.13-sysmacros-glibc-2.26.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/cpio/files/cpio-2.13-sysmacros-glibc-2.26.patch b/app-arch/cpio/files/cpio-2.13-sysmacros-glibc-2.26.patch
index abd1b663496d..90e7bc77bd9b 100644
--- a/app-arch/cpio/files/cpio-2.13-sysmacros-glibc-2.26.patch
+++ b/app-arch/cpio/files/cpio-2.13-sysmacros-glibc-2.26.patch
@@ -10,5 +10,33 @@
#include <sys/types.h>
$3
]], [[switch (0) case 0: case (sizeof ($1($2)) == sizeof ($ac_type)):;]])], [AC_CV_NAME=$ac_type])
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,14 +39,11 @@ AC_C_PROTOTYPES
+ AC_SYS_LARGEFILE
+ AC_TYPE_SIGNAL
+-AC_HEADER_MAJOR
+ AC_C_CONST
+ AC_TYPE_UID_T
+ AC_CHECK_TYPE(gid_t, int)
+ AC_HEADER_STDC
+ AC_HEADER_DIRENT
+-AC_COMPILE_CHECK_RETTYPE([major], [0])
+-AC_COMPILE_CHECK_RETTYPE([minor], [0])
+ AC_CHECK_FUNCS([fchmod fchown])
+ # This is needed for mingw build
+@@ -67,7 +64,11 @@ AC_ARG_ENABLE(mt,
+
+ AM_CONDITIONAL([CPIO_MT_COND], [test "$enable_mt" = yes])
+
+-AC_CHECK_HEADERS([unistd.h stdlib.h string.h fcntl.h pwd.h grp.h sys/io/trioctl.h utmp.h getopt.h locale.h libintl.h sys/wait.h utime.h locale.h process.h sys/ioctl.h])
++AC_CHECK_HEADERS([unistd.h stdlib.h string.h fcntl.h pwd.h grp.h sys/io/trioctl.h utmp.h getopt.h locale.h libintl.h sys/wait.h utime.h locale.h process.h sys/ioctl.h sys/sysmacros.h])
++
++AC_HEADER_MAJOR
++AC_COMPILE_CHECK_RETTYPE([major], [0])
++AC_COMPILE_CHECK_RETTYPE([minor], [0])
+
+ AC_CHECK_DECLS([errno, getpwnam, getgrnam, getgrgid, strdup, strerror, getenv, atoi, exit], , , [
+ #include <stdio.h>