summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-01-06 01:49:46 +0100
committerSebastian Pipping <sping@gentoo.org>2023-01-06 01:51:52 +0100
commit7b414b66e806f0d8f48c949e35017416e4c9517f (patch)
treef97b172c9ec43c93bbe48abf8deb9abe709efb6f
parentnet-misc/gallery-dl: Stabilize 1.24.1 ppc64, #889894 (diff)
downloadgentoo-7b414b66e806f0d8f48c949e35017416e4c9517f.tar.gz
gentoo-7b414b66e806f0d8f48c949e35017416e4c9517f.tar.bz2
gentoo-7b414b66e806f0d8f48c949e35017416e4c9517f.zip
x11-misc/safeeyes: 2.1.5 + DistutilsNonPEP517Build
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--x11-misc/safeeyes/Manifest1
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/Manifest b/x11-misc/safeeyes/Manifest
index 1566e3af3c85..242aeade11fd 100644
--- a/x11-misc/safeeyes/Manifest
+++ b/x11-misc/safeeyes/Manifest
@@ -1,2 +1,3 @@
DIST safeeyes-2.1.3.tar.gz 354494 BLAKE2B 5f7977a8de280f5022cb226689c5b1d48f494932babd014b9ee8affcf9aaa0ef8dfe3ed18c33dbfa4ebaf1c5bfdbed4efc3b69c1ce3065e3ff3c82e83fa71723 SHA512 8a708b3e8f40f75659092a2effb0318b0fb7f47345e3f430f6b83ff2fc3c7de46b2dc881bf69902055bc8233f539946e60822e6ab7a6149f2c99441af1191f48
DIST safeeyes-2.1.4.tar.gz 383245 BLAKE2B 307d58fd589c0a8b01f0c20c21f06a0f81b0d8a43f81e71e79a273a124e00df7cdd2c7c498a4918f6b56abc03fa7cb58db231124a96806a2fe60d6f9dab7f6c8 SHA512 547d00f18e06679464e225ab62f76c43e8efb733e945ae93c02c7cf55ab0bcf5fc078ffc41ad2842a324fff2513050cced404e8bd53d63b78ba7fb1f862c1ad3
+DIST safeeyes-2.1.5.tar.gz 284690 BLAKE2B deedf39bc0a69ee70a692061c96e0ea5ce6aeb09513d7469710d25b8660eaed854b3ee711de4702f839dbfb1f04aee84cb05ebc24d4567fc2b56c04e319f5c63 SHA512 0e4ed1d9f4473b45f6f5d4a74ba4817fca08199072fe937fd3b7ceed1ef543729c618e672198cf4dfeba8ed896b24779ca725f2f2c98bf1c9cdf1a8e9c147dc8
diff --git a/x11-misc/safeeyes/safeeyes-2.1.5.ebuild b/x11-misc/safeeyes/safeeyes-2.1.5.ebuild
new file mode 100644
index 000000000000..b865ffc84d69
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}