summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYifeng Li <tomli@tomli.me>2023-02-19 20:21:17 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-19 20:21:17 +0100
commit7b4388cc6898865367e9ae91385449313c5dfb96 (patch)
tree49f69857eff566674091ec1a1dd7fd71152d82aa
parentsys-devel/gettext: drop USE='cvs' (diff)
downloadgentoo-7b4388cc6898865367e9ae91385449313c5dfb96.tar.gz
gentoo-7b4388cc6898865367e9ae91385449313c5dfb96.tar.bz2
gentoo-7b4388cc6898865367e9ae91385449313c5dfb96.zip
sys-devel/gettext: fix macOS bootstrap build.
When bootstrapping Gentoo Prefix on macOS 13.2 (Ventura) on an Apple M1 system, it will fail at stage3 (note that there are other bugs that prevent the bootstrapping from reach stage3, which must also be resolved) due to the following build failure in sys-devel/gettext-0.21.1: Undefined symbols for architecture arm64: "_gl_get_setlocale_null_lock", referenced from: _libgettextpo_setlocale_null_r in libgnu.a(setlocale_null.o) _libgettextpo_setlocale_null in libgnu.a(setlocale_null.o) ld: symbol(s) not found for architecture arm64 A quick search of the symbol "_gl_get_setlocale_null_lock" revealed that the bug is actually already known - GNU gettext bug 62659 [1]. It failed to find the symbol because GNU's libintl was not present during the bootstrap stage (though it would be installed later), and due to the hardcoded OMIT_SETLOCALE_LOCK value, GNU gettext still attempts to use SETLOCALE_LOCK. Currently the Portage tree already contains a patch for musl. The simplest fix is just applying the same patch to Darwin as well. [1] https://savannah.gnu.org/bugs/?62659 Closes: https://github.com/gentoo/gentoo/pull/29655 Closes: https://bugs.gentoo.org/895330 Signed-off-by: Yifeng Li <tomli@tomli.me> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-devel/gettext/gettext-0.21.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/gettext/gettext-0.21.1.ebuild b/sys-devel/gettext/gettext-0.21.1.ebuild
index 7b9266695787..e7f594906b2e 100644
--- a/sys-devel/gettext/gettext-0.21.1.ebuild
+++ b/sys-devel/gettext/gettext-0.21.1.ebuild
@@ -92,7 +92,9 @@ src_prepare() {
elibtoolize
- use elibc_musl && eapply "${FILESDIR}"/${PN}-0.21-musl-omit_setlocale_lock.patch
+ if use elibc_musl || use elibc_Darwin; then
+ eapply "${FILESDIR}"/${PN}-0.21-musl-omit_setlocale_lock.patch
+ fi
}
multilib_src_configure() {